Firefox and the » symbol – what’s going on?

  • Author
    Posts
  • #10516

    dafyddllyr
    Member

    Ok, the » symbol only seems to appear by my Links, recent posts and archives in Firefox, I can’t seem to get them to appear in IE – any idea why one earth this is?

    And also, at the bottom of my blog, the footer is out by 1px, any solutions?

    To see what I mean, look here http://dafyddllyr.wordpress.com/

    Sorry for this being blank earlier, I accidentaly hit enter… my bad.

    #10706

    The » symbol is inserted as the bullet character using the :before pseudo element, which IE doesn’t support.

    Lots of theme designers use this trick, and it’s a shame, since structurally correct markup like this:

    <li><p>Stuff here</p></li>

    breaks.

    #10711

    wank
    Member

    If you see a theme using this, it’s a pretty good bet it was based on the default. So it’s useful in distinguishing original themes from Kubrick-clones (if they can’t be bothered to change the list CSS they certainly won’t be messing about with the structure) but that is pretty much the only purpose it serves.

    #10712

    dafyddllyr
    Member

    This issue seems to affect bullet points also – I can have bulleted points in my pages no problem, but whenever I try to make a post with bullet points they convert into »’s in Firefox. This seems quite strange to me, as the html is identical in both the page and post, and bullets are viewable in one but not the other

    Is there any way around this?

    #10754

    drmike
    Member

    Get Microsoft and Firefox to follow HTML 4.01?

    #10774

    wank
    Member

    It might be a little more practical to use another theme ;)

    #10775

    drmike
    Member

    That too. :)

The topic ‘Firefox and the » symbol – what’s going on?’ is closed to new replies.