Need help? Check out our Support site, then

Firefox crashing on clicking Image Uploader

  1. Is anyone reporting problems with Firefox crashing when trying to upload images? I have not installed anything new on my desktop, just clicking on the square box to upload images would crash Firefox.

    The blog I need help with is

  2. I use Firefox; just did a test upload which worked correctly.

  3. Log out clear browser cache and cookies, restart the browser and try again.

    Also, have you tried a different browser, such as IE or Safari, or Chrome?

  4. It's working fine in IE and FF 3.5 beta, and it even works fine in Firefox when trying to upload files from Add New media tab (since we get the Select File button from there) but clicking the media icons in the blog post section crashes the FF right away. Did the cookie dance to no avail. Anyway, thanks for confirming, will check other possibilities.

  5. Also having this problem with FF 3.0.10 and WP 2.7.1. Everything works except clicking the image upload button crashes FF. It worked yesterday and I haven't made any software or hardware changes since then.

  6. need help with this also ..

  7. So it looks like there are more people affected? I have switched to FF 3.5

  8. I'm on FF 3.0.10 and have no issues with the image uploader. I just test uploaded 6 images, one at a time, and also in multiples.


  9. I'm on FF 3.0.10 and I've experienced exactly this problem. It only started tonight...
    Crashes a couple of seconds after I press on the image uploader button.

  10. For the record - I also cleared by cache, deleted cookies, and it still crashes. :(

  11. My firefox crashes immediately upon clicking the pic button. Have not added anything. Started last night.

  12. I'm at a loss on this one. I've tried this on FF 3.0.10 on Mac 10.5.6 without issues, and just a few minutes ago I fired up my XP laptop and tried it with FF 3.0.10 on XP SP3 (completely up to date) and again, I had no issues. I uploaded images and inserted them, I inserted them from URL's, I inserted them from the media library... no problems.

    All I can do is shrug and suggest everyone having this issue contact staff directly at .

  13. Thanks for trying. At least I know it's not my computer and I'm not the only one experiencing this at the same time. I contacted support already and thanks again. I have Vista if that means anything.

  14. I'm having the same problem. Very frustrating! Firefox/3.0.10 - WinXP

  15. @pursuingholiness

    You're user name links to a non blog if you're referring to a blog please provide the link if you're not then you will need to head over to

    Also 8 Things To Know Before Posting in WordPress.Com Forums
    And or ? The difference.

  16. t3ck - you're right - it's a wordpress blog but privately hosted. But since I am having the same problem and because it seems to be a WordPress problem not restricted to I decided to chime in. Sorry - it won't happen again.

  17. Well since this appears to have recently started doing this. ( To me also) I think it is safe to assume its a problem with Firefox. Lets just hope it is corrected soon. I have not done any updates to WordPress plugins or widgets lately, so I think Firefox issues are a good guess at this point. I look forward to following this thread till this is resolved.

    Joe Styer

  18. OK, I think I found the problem. I installed Gears on my XP FF install and it now crashes so it is some sort of conflict between Gears and FF 3.0.10.

    Go to tools > addons and disable gears and your problems should go away.

  19. I just passed this on to staff so they can look into it.

  20. Disabling Gears fixes it for me at the moment.

  21. I went back and forth several times and with Gears active, FF crashes. With Gears disabled, no problems.

  22. Thanks for the verification on that ramblerkudos.

  23. Nice catch thesacredpath. This fixed it for me.
    Thank You
    Joe Styer

  24. You got it right. Disabling gears fixes the issue. Thanks.

  25. Winner. Now, visit my blog kooks! Thanks!

  26. tsp, you are like genius to think about that. I never found gears to make my browser faster so I uninstalled it a while ago so I didn't have this problem. Not like any of this is relevant but I wanted to say good catch =D

  27. I just had the problem today, and am going to go try disabling Gears. Hope that works.

  28. @sensico, after I had tried and couldn't get it to fail, I realized that I didn't have Gears running, and all of a sudden thought that might be the issue and sure enough it was. Funny though Gears and Firefox on my Mac get along just fine with wordpress. Go figure.

    Gears seemed to have made a difference on my ThinkPad with XP (which has a slow 1GHz PIII processor and only 512mb of ram), but on my Mac laptop with the core 2 duo, it made little difference. I have it disabled on my Mac, and since I seldom use the ThinkPad, I doubt I'll re-enable it.

  29. Gears make mine abt 5 times faster. But now I have to disable this for firefox to work??? I am having this problem since today morning here.

    No other solution and what is the real cause?

  30. Disallow Gears and clear its cached information.
    Then restart and all should be good.
    The fault here is in Gears not using the correct information.

Topic Closed

This topic has been closed to new replies.

About this Topic