Followers not showing up in stats

  • Author
  • #1357939

    I’ve had several people join as followers but no one is showing up on my stats. Is there a way to fix this?

    The blog I need help with is



    Your blog followers are found here!/my-stats/?blog_subscribers

    Your email subscribers are found here!/my-stats/?blog_subscribers&type=email

    Likes and shares are misleading when you are talking about page view stats. Your followers and anyone with a or Gravatar account who is logged into can “like” and “share” your posts in several locations such as in email and the Reader without ever clicking into your blog and creating a page view stat. It’s only when a visitor clicks into the site that a page view stat is created.

    You can control the length of the entry sent out on your RSS feed here > Settings > Reading. Choose the “summary” setting for your RSS feed rather than to “full text”. That will compel followers to click into the blog to read the full post which will create a page view stat.

    Note that doing that to the RSS Feed does not affect the length of the post displayed on the front page or main page for posts on the blog. To create excerpts there we can split content by inserting “the more tag”

    Also note that you can disable “Sharing” on the same page:
    Settings > Reading
    Add to each article in your feed:
    Comment count

    Changes may not appear until you create a new post or your news reader refreshes.


    My readers have accessed my blog, but the “follow” button appears to be related just to the post they are reading. How can they follow my entire blog and not just the one post?



    Add the Subscribe Widget to your Sidebar

    Dashboard >> Appearance >> Widgets >> Drag and drop the ones you want




    If you would like a follow button to appear on the bottom right hand corner of your site for those who do not have accounts see here >

    Find Friends Who Use WordPress >

    You can customize the contact form with multiple fields, change the email address where you’ll be notified, and mark feedbacks as spam from your dashboard.

    See also Inviting Contributors, Followers, and Viewers
    Note: As a spammer prevention you are limited to sending out 10 invitations at one point in time.



    When I click on the “+blog” button on my stats page I get a blank screen. When I click on the link below I get the same blank screen.

    Your blog followers are found here!/my-stats/?blog_subscribers

    The same is true fpr the comments link. Is there some setting in my browser or in wordpress I need to change to get the list to show?

The topic ‘Followers not showing up in stats’ is closed to new replies.