Font Changes Not Sticking

  • Author
  • #1589960


    Greetings. I have purchased the customization package and have now experimented a bit with various fonts. I have now determined that I want to use the default theme fonts, perhaps with a bit of css editing. So, I go to the customization panel, set fonts back to “default theme font,” then save. The changes do save for a short time, but then they ultimately defer back to the last font that I experimented with. At some point, takes an action to reset this, without my request. Often it is when I access the custom css panel, but I’m not sure that is the only time.

    Theme is Standard.

    Is this correctable? Is is a bug? Am I missing something?

    Thanks in advance!

    The blog I need help with is



    Custom fonts seems to be a bit buggy right now. I’ve tagged your thread for staff review as well.


    I think the problem is only with the preview, and the settings are getting saved on the front end. Can you confirm that if you select your fonts in the Appearance > Customize > Fonts section that they work on the front end but still look wrong in the preview when you close the preview and re-open it?

    Also, what are the fonts are you trying to set as your final choices for heading and body text?



    Thanks for your replies. Fonts selected in the Customize>Fonts section do work, and they seem to look correct after the preview is closed and reopened. The problem is when I try to remove the customization. The change then won’t stick for very long. They do stick at first, but they seem to get lost when you open the Customize>Fonts options again, even without changing or saving anything.

    I’m pretty sure that this is a code bug in WordPress.Com. WordPress seems to revert back to a previously saved state, just by logging into the custom fonts panel, even without changing or saving anything. I’ve verified this by inspecting css before and after. To me, the customization package simply does not work.

    I thought about customization simply by editing the css, but if WordPress is arbitrarily adding to it unpredictably, that is unacceptable to me. I have simply gone back to WordPress.Org.


    I’m pretty sure that this is a code bug in WordPress.Com. WordPress seems to revert back to a previously saved state, just by logging into the custom fonts panel, even without changing or saving anything.

    What you described shouldn’t happen and does sound like a bug.

    I’ve only seen one other similar report where someone said they could save font changes but the settings were reverted any time they made a new change to anything in the Appearance > Customize section.

    First, I’m working to test this in my own test blog. I changed my test blog theme to Chunk, selected some custom fonts, saved, viewed the front end to make sure the save worked, then went back to Appearance > Customize > Fonts and selected the default fonts again. So far, the fonts are stable for me.

    Since I haven’t been able to reproduce the problem in testing so far, would you be willing to try a test on your blog for me so I can document the issue?

    If yes, please go to Appearance > Customize > Fonts in your blog dashboard and change the fonts back to default and let me know in a reply here as soon as that’s done. After the change is made, don’t make any other changes in Appearance > Settings for a few hours and then let’s check it again at that point to see if the font settings get reverted or not. During this test, could you keep a general log of any changes you make to the blog? I want to see if saving something else is triggering the fonts issue for you even though you think it seems to be changing randomly.



    I was setting the blog up in Standard Theme. I only tried Chunk after I reached a point where I could not accomplish anything.

    I have reset the theme to Standard. Interestingly enough, when it reset, it reset to Open Sans, I’m pretty sure. Then, when I activated the customize panel, everything reset on screen to Georgia. The font that showed in the panel was Liberation Serif. I have now saved the setting to return to default theme fonts, but they never did show up on the screen. I’ve called it up in another browser, not logged in, and it is certainly not holding.

    I am not going to touch this blog, so test all you want!

    I’v bounced around a bit trying to find the perfect solution to my website needs. This is not the first time that I have experimented with, and I’m pretty sure that I have noticed this before in various ways.



    Okay, I will take a closer look. Is it okay with you if I test saving different font settings on your blog? If yes, can you please confirm for me that is the blog you’re working on and let me know which browsers you tested? I’m using Chrome 31 and Firefox 26 on a Mac to test.



    You may test to your hearts content! is what I am working on. I use Chrome and Firefox, both set to automatically update. Windows 8 at work and MacBook Air at home. I’ve not seen much browser difference in

    I appreciate your help; I have moved on to for now, but I work with more than one website, so I’d be interested if this can work for me on


    I’d be interested if this can work for me on

    I’m certain it will! Btw, this is only the 2nd report I’ve seen about this exact issue, and I think it only happens to blogs that have something wrong with their settings (that’s my hunch based on the testing I’ve done so far anyway). I may need to get some extra help from our developers to figure it out, and I will start work on testing it today and report back here with what I find.


    I tested your blog and found the same problem as the other report: settings can be saved but every time Appearance > Customize section is opened, the font preview is reset to the Liberation Serif font. If you save anything without selection the desired fonts, the setting gets overwritten again with the “stuck fonts.” This is the 2nd report I’ve seen about this problem.

    In addition, I found loading fonts was a little unreliable when reviewing your blog. However, someone else who helped me test didn’t see that problem.

    I’ve filed this issue as a bug, and the next thing we’ll need to do is wait until the bug can be reviewed and resolved by our developers.

    In the mean time, my advice is to re-select the fonts you’d like to use any time you make changes via Appearance > Customize.

    Sorry for the trouble with this issue!


    Hi there!

    Has any progress on this been made? I didn’t see this thread before I posted this same problem for me. Anytime I’d make any change in custom design, I would again have to go back and change my headings and body text fonts. On the front end, things look fine. It’s only in the admin end that this is an annoyance.

    For what it’s worth, I also posted this here:

    And here:

    Sorry for all the cross-posting!

    I’m using Blaskan theme. The site is



    This exact same thing is happening to me. So now there are multiple cases…


    @ethicalescalator, no word yet! But we’ll reply back a soon as we have more information. Sorry for the trouble!!


    @thomaschh, you are the third person I’ve noted that reported the issue and I’ve started tracking them with a tag “custom fonts stuck.”

    It would help if people who see the problem would post a link to the blog where the problem is happening on one of the threads in the list or tag a new thread with “custom fonts stuck” as a keyword.


    Found a 4th report and tagged it. :)


    I’m experiencing the same issue.

    Not only that but colors aren’t showing up appropriately either. Any coral or red color shows up as red regardless of how dark or light the color is.

    The text font changed for me, but titles and header fonts refuse to show up as jubilat which is the font I’ve chosen for my blog.


    Regarding the red color, the color palette tool has a built in accessibility feature that keeps the contrast for text high enough so it’s still readable for most readers. If you try to select too light of a color, it will auto-adjust. That contrast adjustment might be what you’re running into. Can you let me know you’re exact steps for setting a color and the HEX color code if you’re using the “pick your own color” option so I can investigate and try to verify whether it’s the contrast rules or something else?

    Regarding the font, I checked just now, and all of the headings are showing up as Jubilat for me. Is it possible you’re looking at a cached view? Can you try refreshing the front end page you’re viewing as a troubleshooting step?


    Same is happening to me which is really worrying as I am a beginner, and think it is something I have done wrong. So sorry, but glad others have the same thing, my font sizes and boldness have changed and some are now in upper case not lower. Feeling I should change them all again. It seems that in dashboard/pages/edit they are mixed upper/lower case and in view site these are in lower case as I wanted. Help!


    OK. Looks like the font changes are sticking now. However, when I view my site through my dashboard on Safari, my iPad or my iPhone it doesn’t show a change. If I type in the url and go that route it’s changed.

    As far as the colors go….I went through customizer, choose a palette. One of them had a coral color, but then when I viewed the changes it looked orange and did not really mesh well. I understand the auto-adjusting. But, the colors I chose were not really that light. But, I’ve got a color scheme that works for now. I’d prefer a teal/blue and coral color theme, but since the coral is always coming up orange I’m just going to skip that for now.



    my font sizes and boldness have changed and some are now in upper case not lower

    Hi @steviekillick, what you’re describing doesn’t sound like exactly the same issue as the others described where the font family choices at Appearance > Customize > Fonts aren’t sticking in the live preview but are working on the front end. In those cases, I think it’s a bug that’s not affecting everyone, and I’m still working to gather data on that problem.

    For your case with regard to the mixed upper and lower case and the font sizes and boldness, could you start a new thread at and include a link to a page showing the problem so I can help you take a closer look? I tried checking the blog linked to your username but it seems like that might not be the blog you’re working on.

The topic ‘Font Changes Not Sticking’ is closed to new replies.