Font control using "CSS" versus the "Fonts" Section

  • Author
    Posts
  • #1016799

    jesscy
    Member

    I need help changing my fonts using the “CSS” tab rather than the “Fonts” tab in the Appearance section. I do not like any of the options available in the fonts section but want to control them using CSS instead, but, so far, I’ve found that the Fonts section overrides the other. Very frustrated!

    The blog I need help with is jesscy.wordpress.com.

    #1016959

    raincoaster
    Member

    Yes, the Fonts section overrides CSS. That is why we never recommend hand-coding the font. You’re going to have to hand-delete all that customization.

    #1016960

    raincoaster
    Member

    We once had a guy who hand coded every paragraph so it was white text. Then he switched to a theme with a white background. Imagine what he had to go through!

    #1016977

    jesscy
    Member

    Okay, okay. I see why it’d be easier to change fonts using the “Fonts” section. :P BUT… If I insist on doing things the hard way…

    I’ve been able to change the “menu” and “entry title” fonts on my own with little problem. What I don’t understand is why, even when I change the font in the “Site Title” section, nothing happens?

    I just want to be able to use a different font for my blog title and sidebar (date, categories, etc.) than for each individual posting. And all I want to use are very basic fonts: Tahoma and Palatino Linotype.

    This is what my customized CSS looks like:

    #site-title {
    color:#000;
    font-family:”Palatino Linotype”, “Book Antiqua”, Palatino, serif;
    font-weight:bold;
    font-size:80px;
    margin:0;
    text-transform:lowercase;
    text-rendering:optimizeLegibility;
    letter-spacing:-3px;
    text-decoration:none;
    }

    But “Oswald,” Helvetica, Arial, San-Serif is what shows up on my screen. :/

    #1016979

    This might be a lead….
    Multiple word fonts need quote marks.

    Note: If the name of a font family is more than one word, it must be in quotation marks, like font-family: “Times New Roman”.

    From: http://www.w3schools.com/css/css_font.asp

    #1016980

    Oh shoot, you already had the quotes. Should have read more and puzzled less. Sorry

    #1016983

    jesscy
    Member

    No problem. Thanks for your input, anyway!

    #1017007

    I checked http://jesscy.wordpress.com/ just now and I see you currently have the following CSS saved for the site title:

    #site-title {
    	color:#303030;
    	font-family:"Palatino", serif;
    	font-weight:lighter;
    	font-size:60px;
    	float:left;
    	position:relative;
    	margin:0;
    	text-transform:lowercase;
    	text-rendering:optimizeLegibility;
    }

    That CSS does appear to work. I tested out the example you posted earlier, and that also worked for me. It’s possible that *if* you had left one of the Fonts page selections in place, that was overriding your CSS before (I’m not sure what your settings were when you first wrote in). Please post another reply here if you are still having trouble.

    #1017008

    jesscy
    Member

    Thanks everyone for your help. I started my CSS from scratch and fixed the problem (I think). So I guess you could say this issue is resolved.

The topic ‘Font control using "CSS" versus the "Fonts" Section’ is closed to new replies.