forever theme and sticky posts

  • Author
    Posts
  • #857588

    I am trying to get posts with featured images to show up. I have followed the theme instructions and put a ‘sticky’ on these posts, yet they do not show up on my home page. Help!

    The blog I need help with is jarrettphotography.wordpress.com.

    #857758

    timethief
    Member

    There is a featured posts slider in Forever that appears only on the front page of the site. The dimensions of the featured images in featured posts must be exact, set up porperly to enable featured image dispay in the slider, and marked as sticky posts.
    slider featured images must be 887-px-x-355-px
    Forever theme description> http://theme.wordpress.com/themes/forever/
    Forever live demo site > http://foreverdemo.wordpress.com/
    featured images > http://en.support.wordpress.com/featured-images/#setting-a-featured-image
    sticky posts > http://en.support.wordpress.com/posts/post-visibility/#sticky-posts
    Forver forum threads > https://en.forums.wordpress.com/tags/forever

    #857791

    Thank you for your reply.

    What is the best way to edit photos to be 887 x 355? When I re-size a photo, it leaves the width at 355, but picks a height based on the aspect ratio.

    #857794

    timethief
    Member

    Hi again,
    I don’t rely on the cropper. I do all my image editing prior to uploading the images into my blog.

    #857799

    I edited a picture to be the 887×355, however, when uploading the image into a post, it gives me these options:

    Thumbnail (150 × 60)

    Medium (300 × 120)

    Large

    Full Size (640 × 256)

    What do I do?

    #857804

    Even if the picture has those dimensions, picture insert changes the dimensions. Pictures are still not showing up on the slider

    #857835

    justpi
    Member

    a) Thumbnail, medium etc. – in fact, all the options you can see in the image popup window are irrelevant: they apply to images you want to insert in the post, not to featured images.

    b) A featured image in Forever has to be 888 px wide (or wider), not 887. As for the height, 355px isn’t required: it’s just the maximum that can be displayed.

    c) The slider will show up on your main posts page. I’m not seeing a posts page in the blog linked to your username, I’m only seeing static pages.

    #857870

    Okay, I appreciate the information. Maybe the problem is how I have the ‘About’ page stuck to the home page. I cannot figure out how to do this. I was using the Chaotic theme before and then changed my theme to Forever. How do I get my posts to show up below what I have ‘sticky’d’ to the home page?

    #857874

    justpi
    Member

    In most themes (including the ones you mention) the blog front can display either your latest posts or a static page, not both.

    If you really want your About page page to be your front (I don’t find it a very attractive option), you need to go to Pages > Add New and create a blank page you’ll title “Blog” or whatever you prefer, then go to Settings > Reading and select that page as your posts page.
    Alternative: go to Settings > Reading and set your front to display your latest posts.
    Variant: set your front to display your latest posts, and add the about info to your sidebar (in a text widget).
    Or maybe: switch to one of the themes that feature a showcase/news template (Splendio, Nuntius, Twenty Eleven). The showcase template allows you to display static page plus posts.

The topic ‘forever theme and sticky posts’ is closed to new replies.