Formatting suddenly changes.

  • Author
  • #855316

    I’ve had the same formatting set on my blog since I’ve started it, I even have a template post to copy so everything stays uniform and nice.
    However suddenly the formatting of my posts changed without any… I haven’t done anything different.

    The signature section of the properly formatted post looks like this:

    and after that article they all look like:

    They both have used the exact same template post and I havent tampered with the template since I made it.
    Is there a simple solution for this or are my posts doomed to ugliness from here on out.

    The blog I need help with is



    The words “template to copy” send a chill down my spine. If you have copy/pasted any style tags in the process, you get the result you’ve seen.

    1) please go to your Settings->General and select “WordPress should correct invalidly nested XHTML”. Save the change.

    2) go to Dashboard->Posts, set all the most recent posts to draft, update, then set them as Public again. That should force the change made in 1 to take effect and should solve your problem.



    In the posts you consider properly formatted (they’re not), the image alignment is set to left; in the others the alignment is missing.


    I wasnt copy pasting, I was using wordpresses “copy previous post” and the template doesnt have any body, tags or title.

    I looked in settings > general and there is no option to do anything with XHTML. Just date, time and title stuff. Would it be in a different section for free users? Or not included at all?

    Thanks for the critique…
    How can I replicate the visual formatting in proper technical formatting?



    No, that tickbox should be there, and it’s important. Perhaps check the Writing page of Settings?

    It looks from justpi’s remarks like you just have to change image alignment in those posts that are messed up and in future ones, remember to set the alignment before inserting the image in the post. That should prevent this from happening again.


    The issue that I’m having is that I want the bar and the name and signature to be beside the image but still to the left. But no matter what I do it pushes all the text onto the next line after the image.

    I did the xhtml thing though. hopefully it’ll keep everything functional in the future, but it doesnt fix the signature issue I’m having now.


    Should I be using tables to correct this? I haven’t used them in html in years… so I’m gunna have to re-learn how to use them.


    I guess to finish the topic of this thread.

    Does anyone know why wordpress displays a border around tables even though I set the border value to 0 and the frame value to void?



    a) It wasn’t a critique, it was an alert: the code of the image is messed-up (probably because you had initially inserted the image as a captioned image then removed the caption by highlighting it and deleting it in the Visual editor).

    b) Your “signature section” should be like this:

    <a href=""><img class="alignleft" title="GaianHavatar" src="" alt="" /></a>
    <h2 style="margin-top:44px;">~Gaian Helmers</h2>

    You can change the margin number to adjust the vertical positioning.

    c) Some themes are designed to display table borders by default. See here how you can override that:


    Thanks so much justpi. It all works well and looks exactly like it should. I updated my template and everything should now be consistently functional.

The topic ‘Formatting suddenly changes.’ is closed to new replies.