Need help? Check out our Support site, then


Front page problems

  1. Hello, I am just beginning to blog. Only 2 practice posts so far. My question is about the themes and front pages. I keep choosing themes based on appearance in demo. Currently playing with Chateau. The issue is that the posts are not appearing on the front page or home page as they do in demo. I have to hit the 'Blog' link at the top to get to the posts. What I like about the Chateau demo is that the most recent post appears prominently on main page with previous posts listed below it. How do I achieve this design? Thank you.
    Eukaryote Voter

    The blog I need help with is eukaryotevoter.wordpress.com.

  2. Same issue for me. I can get the full page to display (and this is how I've been using it for 6 months), but now I want to have the shorter most recent post with more below. Not sure how to get this.

  3. I resolved this one for me. I needed to alter the Reading settings through the full edit view (your.site.url//wp-admin/options-reading.php). There I changed the following setting:

    Blog pages show at most XX posts.

    I tried it at 11 (1 for the top, 10 below) and it works fine now, though I'll need to go to all posts and put in a "read more" break so when they are at the top, they break rather than display the whole thing.

  4. I'm having front page problems too with this theme having solved the issue above with your advice. What happens now is that I post OK, it appears on the front page, I click to visit another page, but when i return to the front page ...... it's blank, the posts have vanished!! My site is http://www.thetwodoctors.wordpress.com

  5. brianmetters: I'm not experiencing the same issue with your site as you describe. How do you "return to the front page"? I tried going to your site, clicking on one of the archived posts in the list below, and then clicking Posts again, or the browser's back button, and all archived items are still there.

  6. twopearces: thank you for following up on my plea. I think I solved this about 10 mins ago but was unsure till someone else tried it. What I found was that the previous menu item (Blog) when clicked was taking you to the blank Blog page at http://www.thetwodoctors.wordpress.com/blog used for posts. What I did was to remove the Blog page link from the menu and create a new one called Posts with an external link to the main site address without the /blog part at the end. It works, but it was nothing but Trial and error after changing almost every setting for Writing Reading Theme Options available.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags