Full-width, no sidebar not cooperating

  • Author
    Posts
  • #720385

    friendlyfish
    Member

    I want to publish on my blog page on this site in the Elegant Grunge theme. I’d like it to be the full page, no sidebar (blog page). I set the drop down to that for template on page attributes for the blog page. When I preview it the sidebar is still there. Why is that?

    Do I need to create content on the page or publish a post first perhaps?

    The blog I need help with is friendlyfishmedia.com.

    #720513

    micahcooksey
    Member

    Hello,

    It works when I try it… Are you sure you clicked the “save changes” button before you previewed it?

    You might also try clearing your browser cache if it still won’t update.

    #720554

    friendlyfish
    Member

    When you say it works, you mean that there’s no sidebar there, correct? I can’t get it to be removed. Saved/updated it many times. Cleared cache. Still no go.

    My wording was a bit convoluted so am just checking.

    Thanks for your reply!

    #720559

    micahcooksey
    Member

    Yes, that’s right.

    Just to humor me, could you go through the instructions on this page just to ensure that this isn’t something having to do with your browser?

    #720568

    friendlyfish
    Member

    Wow. Did all steps but very last two. Still showing sidebar. Will need to check other computers/networks tomorrow.

    Thanks again!

    #720572

    Can you give us a link to the page you are talking about?

    Also, the post/page preview has in the past been known to not display some things correctly, so it could be the case this time. Try publishing a temporary test page with the no sidebar page template and then view it on the site itself and see what things look like.

    #720577

    friendlyfish
    Member

    Here’s the link to the problem page: http://friendlyfishmedia.com/blog/

    And Test Page:http://friendlyfishmedia.com/test-page/ … which, as you may see (at least I do), worked.

    Would you suggest that I just delete the problem blog page and add a new one. Thankfully I’ve not published anything to it!

    #720578

    The no-sidebar page template setting will not work on a page that you set as the “posts” page at settings > reading. That is why the “blog” page has the sidebar.

    You can set the entire site to have no sidebar by selecting the “full-width” layout at appearance > theme options.

    #720582

    friendlyfish
    Member

    So the “posts” page must have the sidebar. What’s the logic for that? … just curious, since I have ya here!

    And yeah, I may just select full-width for the whole site.

    #720586

    Typically things that go into a sidebar are post related such as the categories, recent posts, recent comments, archives, etc., widgets, so it would be useful to readers to have them on the posts related pages.

    The page templates are only for static pages. The post related pages (archives, categories, single-post and main posts page) are dynamic. In other words they do not actually exist until requested by a browser. When you create a new posts page and set it at settings > reading, it is no longer a “static” page. It is magically transformed into a dynamic page to display your posts. Hence the page templates will not work with it.

    #720588

    friendlyfish
    Member

    Dang TSP, that’s a wonderful explanation. Thank you very much!

    #720592

    You are welcome.

The topic ‘Full-width, no sidebar not cooperating’ is closed to new replies.