Function Buttos Displaying Inproperly

  • Author
  • #1326489

    I will explain this the best I can: I seem to be having a problem with the display of what I want to call the “function icons.” ie.–the formatting buttons in New Post & the Notification button on my blogs Main Page. In IE 8 they don’t display at all. In Firefox 21.0 they appear as tiny boxes with what appear to be a letter followed by numbers. I hope that is a fair description. I have seen this before, it’s as if they appear to be “broken link” icons, but they still work, at least in Mozilla. They aren’t appearing at all in IE. I notice this when I view any WordPress blog and am not having this problem with any other sites. I have cleaned out my cookies and cache, not that I’m unfamiliar with the procedure, so I have no other explanation except to think that it is on your end.

    Thank you.



    Without knowing every one of your specific computing environment details we cannot create a parallel set up to duplicate any issue you may be experiencing and assist you with resolving it.

    If you are not running one of the browsers and versions listed at please try upgrading or switching first.

    The most recent version of Firefox is 22.
    The most recent versions of IE are IE 9 and IE 10

    Note: If you are using an IE browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see >

    If you are running one of the browsers and versions listed at please do these four things:

    1. Try clearing your browser’s cache:

    2. Make sure that you have third-party cookies and JavaScript enabled:

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS:

    If it’s still happening, let us know exactly which browser (and version of it) you’re using by checking here if necessary and also post any error reports you get.


    I use Mozilla as my main browser. Ironically, it upgraded to 22.0 this evening.

    However, I opened IE and switched the compatibility and am able to view the Function & Notification buttons normally.

    I went back to Mozilla and complied with everything that you listed, but I am still unable to view the Function & Notification buttons normally.

    I did recently rest both my browsers; this may have been what caused it.

    Is there a comparability toggle in Mozilla?

    Thank you.


    Thank you for your help and patience. I believe I have solved the problem by doing a clean reinstall of Mozilla.


    Again, thank you very much.


    I am still having issues with the “function” buttons displaying properly in Mozilla 22. i.e.–the notification button in the upper-right hand of my page as well as the editing buttons when making a new post. They display a small box that appears to have the letter F and some other garbled information.

    I have gone through the check list, enabled and disabled add-ons and functions in my browser, I have cleaned out the cache & cookies, and ran multiple registry and virus scans all coming up clean. The only thing that seems to work is a complete reinstall of Mozilla; however, since this post, I have reinstalled the browser three times, most recently last night. However, after only being online a short time this morning and doing minimal
    surfing, they are displaying improperly again.

    I don’t seem to have issues with the pages in IE or Chrome; however, despite repeated efforts I cannot get the function buttons to display right. I don’t have the issue with any other site than with my WordPress blog. I feel there is some incompatibility going on between WordPress and Mozilla, and yet apparently, as nears as I can tell, it is only the version of Mozilla that I have on my particular machine.

    I am still running XP, could that be one of the issues?

    Thank you.



    Hi there,
    I’m sorry I could not help. I’ll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

    P.S. I’m also running Windows XP and using Firefox as my primary browser so my answer to your last question is no.


    I feel the problem is with the browser, but I am at a complete loss as what to do. I noticed a similar display error on a Tumblr blog today. It wasn’t, and I will use the term “rendering,” a “reblog” link on one particular blog. I viewed this same blog in IE and Chrome. I wasn’t too surprised that IE rendered the page completely different than both Mozilla and Chrome. Nevertheless, I was getting the same display error that I get on my own blog.

    This is frustrating and it makes one think they picked up a bug somewhere and yet it is only Mozilla that appears to be corrupted.

    Thinking back, when it first started happening, I was running Mozilla 21, ironically, and I think you can review my posts here, it upgraded to 22 on my first reinstall.

    I had read somewhere yesterday, when searching for an answer, that Mozilla is in the middle of a new build. Apparently, 23 is set to be released sometime in August, with a final build to 24 in Oct that would sport some radical changes.

    I can’t help but think I’m in the wrong place at the wrong time, and yet I don’t know anyone else who is having this problem.

    The error still takes place even in safe mode. Resetting the browser doesn’t help either, only a fresh reinstall after deleting all profile folders. The only thing I haven’t done is try to clear out the registry keys, but I’m not very comfortable doing that.

    In any case, I wanted to say that I don’t feel there is a fault with my WP blog in particular, but there is something about these particular function links that isn’t rendering properly in, at least, my Mozilla browser.

    Thank you again.



    Could you send us a screenshot of the page where you’re seeing this? You can upload the screenshot to your blog’s media library.


    I’m going to try a reinstall one more time. I downloaded a different exe. file using IE this time. I have had problems before with Mozilla corrupting downloads. It was, actually, a considerably different install. I am also installing my add-ons, what few I use, slowly throughout the day to see if one of them is causing the error.

    I’m keeping my fingers crossed here.

    If it starts happening again I will post a screenshot.

    Thank you.


    Okay, this is what I’ve done. I had two techs scan my machine for bugs, and none were found. I had actually reinstalled Mozilla and my blog was showing no errors; however, while my tech was here Mozilla started displaying the error. Then seem to think it is something with the your code that is causing the error. I uploaeded a screenshot of a New Post page and you can see the errors in the editing feature as well as on the left sidebar.

    This only started happening from the date of my first post, which in effect, almost coincides exactly with the day Mozilla took the upgrade to version 22.

    Thank you, any help or thoughts would be appreciated. I feel I have done everything on my end that I can. I’ve been thorough the initial checklist that I was given, I have tried viewing the site in safe mode, I have reset Mozilla, disabled, even uninstalled my add-ons….

    I’m at a loss.



    Could you please follow these instructions to activate and enable JavaScript in Firefox.

    1: In the Tools drop-down menu, select Options.
    2: Next, select the Content icon/tab at the top on the window.
    3: Then, check the Enable JavaScript checkbox under the Web Content category.
    4: Hit OK to close the Options window and save your changes.
    5: Finally, Refresh your browser.

    Otherwise try this guide to reset your browser:


    My java script is enabled. I have already tried resetting the browser, numerous times and have viewed the site in safe mode. These icons, or whatever they are, still do not display properly.


    Were my Java script not running, wouldn’t I see more similar renderings? In any case, I found this concerning Mozilla, and I believe it is the current version 22:

    Nevertheless, I see no such icon on my address bar where I can “alllow” jave, on my blog, or any site for that matter.



    Are you running any malware/anti-virus software? if so, could you please try to temporarily disable these?


    Actually I did try that. I had an issue once before when AVG took an update and labeled a script on WordPress as suspicious.

    I have a really good feeling that the problem lies within the Mozilla browser itself. The recent upgrade to 22 coincided with when the error started occurring, or there is something within my extensions, and yet I use the same extensions on Chrome–Stylish & Ad Block.

    I did another clean reinstall yesterday; however, I have not added my extensions yet. I’m still trying to figure this out, even though I know when I have my extensions install, and disable them, the functions still display incorrectly.

    There seems, I think, that once the extensions are installed, regardless if I disable them, Mozilla is reacting to them in a not-sop-user friendly manner.

    Mozilla’s support boards are full of errors caused by the last update, and most of them seem to be caused by what are now ‘incomparable” extensions, unless of course you get lucky.

    But your guess is as good as mine.

    I’m going to run Mozilla without any extensions and see how it goes. Then I might add at least Ad Blocker Plus back, but if that one fails I’ll probably abandon the browser all together. because everything works fine in Chrome.

    Microsoft can have IE. That thing can’t hold water.

    I may look into Opera as well.

    I’ll let you know how it goes. Thank you.


    I’m still not having any luck. Whats more, I can’t even register at Mozilla support so I can post my problem. I have tired several times over the last couple of days and their system won’t send me a confirmation email.


    I have to tell you that I have had a third tech say that I am having compatibility issues between Mozilla 22 and WordPress. Why it is only me, that I know of, I have no idea, but I do realize how software is and we know Mozilla did a recent upgrade.

    For whatever reason, I cannot get Mozilla support to respond; the support forum page will not send me a confirmation email and I have tried it in all three browsers.

    In any case, as per my screen shot, and despite my best efforts, Mozilla is still displaying these images incorrectly.

    I apologize for my persistent frustration.


    Okay, I got into Mozilla support (the password I was making was too short and didn’t include a numeral) I started a thread:

    …and this is what they have told me about the pages on my blog. I’m not as technically savy as I wish I was, except for the basics . The one suggestion makes the most sense concerning the font. Can anyone here add to that, if so, please.



    It’s definitely a display issue caused by Firefox. Please wait for another response from the Mozilla admin/contributor and follow their suggestions.

    If it were a font issue on your computer it would also occur in different browser. In your case it doesn’t.


    Personally, I feel the same way and I believe my tech feels so too. After a reinstall, my blog looks fine for day or so, and then the display blew out. I don’t think I’ve overly tweaking the browser or am I running loads of extensions. Feel free to log into their support and put in your two cents in defense of WP.

    That might be rather interesting to read and it might start a fire under their fox; they were quick to respond but now they have nothing to add.

The topic ‘Function Buttos Displaying Inproperly’ is closed to new replies.