Gallery mosaics and the mobile theme not showing all pictures

  • Author
    Posts
  • #1054349

    johnconners
    Member

    While I love the new mosaic gallery feature, it doesn’t seem to work too well in the mobile theme. An example is this gallery on my site which on an iPhone (screenshot below) has a bunch of photos missing:

    http://db.tt/p83pLbN5

    If I change the user agent in Chrome to match my iPhone it looks fine, it’s just when running on the actual device that it fails to work properly. I’ve looked at a variety of other mosaic galleries on wp.com and notice the same problem, including the original post on the wp.com blog about mosaics. Looks like a bug in the mosaic rendering as I’m not overriding the CSS for the mobile theme – possibly it’s trying to fit the images into too narrow a view port. Any ideas (other than implementing adaptive CSS in my theme and switching the mobile theme off)?

    The blog I need help with is johnsadventures.com.

    #1054451

    justjennifer
    Moderator

    This was reported earlier by a user who has an Android phone. https://en.forums.wordpress.com/topic/how-can-i-make-tile-galleries-look-great-in-mobile-theme?replies=2

    While it looks that support for the Image Carousel was added to the mobile theme, the new Gallery tiled mosaic was not.

    #1054452

    justjennifer
    Moderator

    I’m going to tag this for Staff input. Since it is the weekend, we may need to wait a while for an answer.

    #1054455

    johnconners
    Member

    Ah yes, I did see that other post however couldn’t confirm it as the page linked to 404’d. The mosaic gallery should work on the mobile theme so I believe support has been added, it’s just I think there’s a width bug in it. Anyway, thanks! :)

    #1054459

    justjennifer
    Moderator

    Thanks for pointing it out. I’m not aware from the announcement that support for the tiled mosaic itself was added to the mobile theme, but we’ll have to wait for Staff input.

    #1054607

    justjennifer
    Moderator

    Seems that Staff have removed the modlook tag here, although I am not certain I understand the reason.

    Regardless, here’s info on using mobile themes http://en.support.wordpress.com/themes/mobile-themes/ which includes info on using them with the Custom Design upgrade. Perhaps that will give more info. Otherwise, if you have any question on that, best to post in the CSS Customization forum.

    #1054609

    johnconners
    Member

    Yeah, thanks for that. I’d rather avoid having to style around the mobile theme’s style issues if I can (as it’d be simpler just writing my own mobile theme support instead), I guess I’ll just switch it off until someone gets around to fixing it!

    #1054611

    johnconners
    Member

    On further investigation the problem is that the widths that the mosaic generates (it outputs width and heights of each cell) are slightly too large when rendered on an iPhone to fit in the page – probably only out by a few pixels. Even if you don’t use the mobile theme the cell sizes remain the same so it’s the carousel / mosaic generator that’s getting the sizes wrong so there’s nothing that can be done, even with custom CSS, to change it I believe.

    #1054620

    justjennifer
    Moderator

    @johnconners-I’ve readded the tag for Staff assistance in the hope that your concern will be addressed.

    #1054623

    macmanx
    Staff

    We are aware of the issue and working on it.

    The problem is more the complexity of the javascript in the mosaic gallery and the processing power of some mobile devices. We’re working to get that optimized.

    #1054627

    johnconners
    Member

    Excellent, thanks! And good luck! :)

    #1054628

    macmanx
    Staff

    You’re welcome!

    #1054640

    tryphoon
    Member

    I actually see a similar problem when simply resizing my browser window (see http://wp.me/puOAH-7pa and resize the page width)…

    Is this an issue that can be exacerbated by a precise theme?

    #1054643

    justjennifer
    Moderator

    It seems there are also display issues with the Gallery “types” on flexible width themes.

    #1054644

    johnconners
    Member

    Thought I’d report back and with the mobile theme enabled the gallery now behaves itself and does what it should do on both an iPhone and Android phone so looks like the issue I mentioned above has been fixed. Nice one! :)

The topic ‘Gallery mosaics and the mobile theme not showing all pictures’ is closed to new replies.