Need help? Check out our Support site, then

Get "You are not allowed to delete this post." error when I try to delete photos

  1. There isn't an issue when you view my blog

    I was trying to clean out my media library of old photos that I don't have in posts anymore; I selected a whole page of photos, tried to 'delete permanently' with bulk actions, and it took me to a page with the error "You are not allowed to delete this post."

    I had previously (a while ago) deleted all the posts and re-did my entire blog, but never deleted the photos. I just want more room for photos I'm actually using.

    Any ideas or questions?

    Thanks for any help!!


    The blog I need help with is

  2. Well, it appears to be working now...? lol

    I just kept trying and it gave me the same error so I tried a different page and then noticed at the top, where it used to say 22 pages, it now said 18, so it's been deleting them.

    Not too sure what that was about but my problem is solved.


Topic Closed

This topic has been closed to new replies.

About this Topic