Getting rid of the link border

  • Author
  • #440904


    I can’t seem to get rid of the annoying blue link border around my images on my sidebar. If you don’t know what I mean..take a look at the “Join Zell’s Pinstripe Forum” image in the top right corner of the sidebar( It has that blue link border around it. What I want to know is..what do I need to delete on my stylesheet in order to get rid of it.

    Thanks in advance.


    The blog I need help with is



    The blog you specified at does not appear to be hosted at

    This support forum is for blogs hosted at If your question is about a self-hosted WordPress blog then you’ll find help at the forums.

    If you don’t understand the difference between and, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It’ll help people to answer your question.

    This is an automated message.



    My blog is actually hosted at It even says it at the bottom of my website. Can anyone help me out here?



    You must be using an IE browser> I can’t see a blue border and I’m using Firefox 3.5.7

    If you click on your images, you’ll find they open as a file, just the image with no page around it. The border is showing because the image is linked. If you don’t want your images linked, the solution is easy: just select Link NONE when you upload the image. If you DO want it linked, you’ll have to fiddle a bit. Here is the answer I found by searching the forums for “Image border”:

    Also here’s post that sets our ways to get rid of some unwanted features in the MistyLook theme:



    I forgot to post this fact. The CSS editing upgrade is not required to remove the border. It’s also not needed to remove the unwanted features in the post I linked to above.



    Yes, I am using an IE browser. First off, I want to state that the images linked on my blog…are linked for a reason. I’m not trying to get rid of the links, but rather the border that surrounds the images. And I’m not talking about links to the pictures in my posts..I’m talking about the borders surrounding the images in my sidebar.



    I did understand you. Did you try what is set out in 2.) in the forum thread I linked to above? It seems that you could create a draft post and go through the process outlined and then copy and paste the result into the text widget.

    2.) Or if you want the image to link to something:
    Edit your post after you have inserted the image by clicking the image and choosing the mountain icon. Choose “Advanced Settings”
    Then on the line “image properties”
    on “border”
    type in “0” (zero)
    (You can do this in html if you are comfortable with that as well)

    Might be do-able with CSS, but you’d need the upgrade ($) and experience.



    #2 is about editing a post…I’m not trying to do that. I’m trying to do it with CSS..and I don’t know how.



    Here’s the thing about the CSS upgrade. It’s not recommended to those who have no CSS experience because there is not Staff support for learning it. We have a couple of volunteers who will help from time to time and that’s it. So when you purchase the CSS upgrade you are expected to be able to work independently. If you can’t do that there’s a time limited opportunity to get a refund.

    Setting that aside, although you keep rejecting the notion you could copy and paste the code you have in each text widget in your sidebar now into a new draft post. Save it then editing it to remove the border from the linked image as outlined in 2.). (This will provide you with the correct html. ) You can then click and switch from the visual editor to the html editor, and copy and paste the code into the text widget, and go back and delete the draft.




    Add this to your CSS

    #sidebar img {border: none;}

    That should get rid of the border surrounding the images in your sidebar.

The topic ‘Getting rid of the link border’ is closed to new replies.