GIF transparency – did work, but now doesn’t

  • Author
    Posts
  • #393429

    fretjam
    Member

    Hi, my first two posts seemed fine as far as keeping my GIF images transparent. I have not changed anything about how I save or upload the GIFs and now, when writing my 3rd post, for no reason the transparency doesn’t work and the images have a black background.

    This is how it’s showing in preview mode as well.

    Any help appreciated.

    The blog I need help with is chordprogression.wordpress.com.

    #393533

    Please paste the exact URL of your blog when asking questions here, or link your nickname to your blog (as explained in the Sticky 8 Things to Know Before Posting). We can’t help without that.

    #393534

    fretjam
    Member

    Sorry about that. Please see the below post for an example of when transparency worked…

    http://chordprogression.wordpress.com/2009/08/21/guitar-chord-progression-2/

    I don’t have an example of when it doesn’t work, because I don’t want to publish images with black backgrounds!

    Hope that helps.

    #393538

    It doesn’t.

    #393539

    fretjam
    Member

    No I thought it wouldn’t!

    Ok, I will just have to create the images with a grey background then.

    #393540

    If you are so keen on not going public with a defective post, you can temporarily create a new page instead, make it a child page so it won’t show in your header, and just give us its name.

    #393723

    justjennifer
    Moderator

    I’m having the same problem; it has to be something fairly recent that’s changed because I saw this page not a week ago and GIF transparency was working just fine.

    This is what I’m now seeing on my blog: http://justjennifer.wordpress.com/files/2009/08/20090823-screenshot.jpg

    #393745

    @justjennifer: remove height and width from the image code.

    #393748

    justjennifer
    Moderator

    Bingo! Why on earth would that have been the cause? (Just for the sake of edification.)

    #393749

    justjennifer
    Moderator

    and again thanks for getting me out of hot water!

    #393775

    Don’t really know why: I knew that GIFs don’t work if resized, so I figured it might be a complication related to this.

    #393776

    justjennifer
    Moderator

    Hmm…which is why I wondered if something was going on behind the scenes.

    None-the-less, all fixed. Ta!

    #393782

    vikasjnu
    Member

    Same here! All gif animation gone! I tried all tricks [removing border etc.] ;nothing works! :(

    #393783
    #393790

    Hi, all our animated gifs were working perfectly first but now only few of them are working almost only in old posts… We post animated gifs from long time on our blog so this is a new problem we had never before…

    Our blog is http://conme.wordpress.com/

    someone would know how to help us, please? … :)

    #393791

    How about reading my 10:03 PM reply above?

    #393794

    :) Thank you a lot Panaghiotisadam, I’m sorry but I dind’t understand your 10,03 pm post… my English’s gone :( Now I see that it works in 2 animated gifs but we have a problem because we had to remove heigh and width from animated gifs from march to now, a lot of animated gifs!!…and they were working perfectly yesterday… I’ll do it but I find it strange isn’t it?

    #393795

    You’re welcome. Yes it is strange – probably wp staff making changes again.

    #393821

    kinialohaguy
    Member

    panaghiotisadam,
    I upload GIFs and do not change them or resize them.. They used to work, but now they don’t.
    http://kinialohaguy.wordpress.com/
    I have followed your advice in previous posts, but I have not been able to get my gifs to work.

    #393822

    @kinialohaguy: I don’t think you’ve followed my advice. That advice was: go to the html post editor and remove the width and height commands from the image code. For instance, the flag in your “Happy 50th Hawai’i Statehood” is this:
    <img class="aligncenter size-full wp-image-1491" title="HIflag" src="http://kinialohaguy.files.wordpress.com/2009/08/hiflag.gif?w=132&h=99" alt="HIflag" width="132" height="99" />
    Turn it into this:
    <img class="aligncenter size-full wp-image-1491" title="HIflag" src="http://kinialohaguy.files.wordpress.com/2009/08/hiflag.gif" alt="HIflag" />

The topic ‘GIF transparency – did work, but now doesn’t’ is closed to new replies.