Need help? Check out our Support site, then

Glitch (?) with category hierarchy

  1. [I've tried browsing this subject, but can't claim to have spent a day tracking down other posts relating to it]

    I recently added a category "industry commentary", underneath "technology" (which is in itself under "general"). I did this while writing a post. The "industry commentary" category it got attached to the post and is listed as a category in my sidebar widget, but never appeared in my list of categories in dashboard.

    Assuming that maybe WordPress might catch up and update itself later I pressed on with creating some sub-categories of this, including "sas", "ibm", "oracle" etc. When I created each of these, "industry commentary" appeared as a parent option in the drop down. Again my category widget shows general->technology->industry commentary->ibm and the rest fine.

    I can filter post quite happily in dashboard using "industry commentary" and its children, however the category still does not appear on the category list/edit page in dashboard. I had two pages, it was on neither. So I increased the number shown to more than my total categories, still invisible. Then I search for it, nothing returned.

    I also noticed that the ibm, sas etc. categories have a weird structure to them when I click on them. An example appears below:

    It's like the hierarchy is being descended from "general" down to "industry commentary" at which point the next level has all the prior ones included in it?!?!?

    By way of contrast, here is a more normal URL:

    Have I hit some limit on the nesting of categories, or (as I am beginning to suspect) does "industry commentary" have some sort of shadowy half existence (a al Schroedinger's cat).

    I can't even delete "industry category" and start again as it is not selectable in the edit categories panel.

    I am very confused now.


    The blog I need help with is

  2. Sorry - as if I hadn't written enough already - none of the children of "industry category" (e.g. "ibm", "sas" etc.) appear in the dashboard category editor either.

    Here are a couple of images illustrating the problem:

    My category widget (which looks fine):

    My dashboard category editor (which can't find anything with "industry" in it):


  3. More info:

    The category clearly exists (at some level) as I can't add it as new. See:


  4. Argh! Now have a counter-example to the weird nested URL above:

    is what I would expect to see???


  5. So all the child categories don't show up in the dash?


    And this is what you'd expect to see as Oracle is a child cat of technology which is a child cat of general.

  6. Hi,

    Have been out for a Friday night meal (UK-based).

    Although "industry commentary" appears in all of the filters and lists of check boxes (as do it's children - e.g. "oracle" above) and can thus be allocated to posts, I can't see the category (or its children) in the edit categories panel of dashboard, nor do they appear if I search for them there. However they do exist, because if I try to add them on the dashboard category panel, I get an error saying "category already exists".

    A subsidiary issue is the weird URLs for the children, while the "oracle" one above works, this one doesn't:

    Instead it's:

    with the weird embedded "sas-industry-commentary-technology-general" bit at the end.

    Hope that makes sense.


  7. Anyone else ever have this problem?


  8. Just had a note from tech support that they are looking at this, so hopefully there will be a resolution.


  9. Now fixed by the helpful people at WordPress - thanks guys.


  10. Thanks for posting, but I don't see anything fixed. All the subcategories of "industry commentary" except "oracle" still have the weird permalinks.

    I had tried this in my test blog, but no matter what I tried I couldn't reproduce the "never appeared in my list of categories in dashboard" part, which must have been the key to this weirdness. (I'd like to know the Support answer on that.)

    Re some of your questions: a) the permalinks should be the way oraccle is, b) it's got nothing to do with the level of nesting - I went further than that with no problem.

    Re an irrelevant issue (your use of tags): a) more that a combined total of 12 tags and categories per post exclude you from the global WP pages, b) categories and tags function in exactly the same way, so there's no point in using the same word or phrase as both a category and a tag in the same post.

  11. The occasional missing category issue has been fixed on

    The permalink issue is the result of the the above bug.
    Newly created categories (including the whole path) will have clean structure.

  12. You created tags named "orable", "sun", "sas", "microsoft", "ibm", "erp" in some posts.
    Then you created those names as categories. Because the slug/permalink for those words
    were taken for tags already, so WordPress uses the long form for category instead.


  13. @drhailin: The very link you give says:

    "If you publish a post attached to a category ‘food’ and with the tag ‘rice’, the URLs will look like this: "

    So your hypothesis is not correct.

Topic Closed

This topic has been closed to new replies.

About this Topic