goodreads

  • Author
    Posts
  • #863287

    juantc
    Member

    Desspite following the wordpress instructions re goodreads’ author id, The widget still doesn’t show my shelf – any ideas?

    Thanks

    John

    The blog I need help with is indielitmatters.wordpress.com.

    #863421

    timethief
    Member

    Just to be clear did you use this guide?

    Note for GoodReads Authors: Your author ID may not match your user id. If you enter the id as retrieved above and it doesn’t display your bookshelf, you’ll need to fetch your ID from your public author page. You may need to log out of GoodReads first (or have a friend help you). Visit your author page, and then hover over or click the “add as a friend” or “send message” link on the left under your author photo. http://en.support.wordpress.com/widgets/goodreads-widget/

    #863448

    wisealpha
    Member

    I did it every steps but it did not work. goodreads
    widget still doesn’t show my books :(

    #863449

    timethief
    Member

    The widget states “no books in this shelf yet”. If you do have books on your shelf at goodreads then have you checked goodreads “help” http://www.goodreads.com/help or contacted goodreads support to see if there are known issues at that end?

    #863476

    juantc
    Member

    There’s no problems at goodreads. The books are showing on the shelf. But the author id accessed as instructed by wordpress doesn’t work…?

    #863478

    timethief
    Member

    I’m sorry that’s happening to you and you cannot find out what to do by using the support documentation http://en.support.wordpress.com/widgets/goodreads-widget/ I’ll flag this thread for Staff attention.

    #863492

    macmanx
    Staff

    The issue appears to be on GoodReads’s end. I recommend contacting them about this.

    #863494

    wisealpha
    Member

    I’ve been tried for 1,5 hours and read the support documentation but the bookshelf does not shown on the homepage. Yes, I can see the bookshelf on Goodreads but not on my blog.

    #863495

    macmanx
    Staff

    As stated, the issue appears to be a problem on the GoodReads end. You’ll need to contact them.

    #863496

    wisealpha
    Member

    I found the link below:

    http://www.goodreads.com/user/edit?tab=widgets

    How can we use the HTML through this link?
    It gives “Copy/paste this HTML into your Web site”.
    Could you please check this out?

    #863505

    exquisi
    Member

    I’m having the same problem, and Goodreads said that I should contact you! Please help…

    ps: Thank you SO much for doing a Goodreads widget in the first place.

    #863512

    exquisi
    Member

    Also, if someone on the staff is going to check out the widget, there’s another issue: when you put in a title for the widget (for example, “Recommended Books”) and you choose a shelf, the title is replaced by the shelf name AND the shelf name appears inside the box as well.

    Seems like it should be possible to have one title for the widget itself and then the shelf name inside the box but that doesn’t work.

    Frankly, I’d prefer no shelf name listed inside the box because we can add our own title to the top of the widget! Thanks for listening…

    #863529

    theianfox
    Member

    I’ve just added the widget to my blog and it works fine.

    The WordPress instructions state just add the numbers from your numeric ID. I did that and it didn’t work.

    I then added my whole id, meaning numbers and name

    8631293-ian-fox

    It then works.

    #863575

    juantc
    Member

    Thanks for that ianfox – I tried as you suggested and yes – it works! Much obliged :-)

    #863576

    timethief
    Member

    @theianfox
    Great catch and thanks so much for sharing it.

    #863682

    Still won’t work for me. I tried everything, deleting the widget, reinstalling it. Putting just the number ID or the whole name. Still would just say “no books on this shelf yet”. It did work some days ago and I didn’t change anything, so that’s really weird. Any ideas?

The topic ‘goodreads’ is closed to new replies.