Google authorship does not work despite connecting Google

  • Author
    Posts
  • #1609824

    anaspoke
    Member

    Hi, please help – I have successfully connected Google+ and even ended bylines and info in user profile, yet structure testing tool still says that my page does not contain google authorship.

    Thank you in advance.

    Ana

    The blog I need help with is anaspoke.com.

    #1609884

    a1jesin
    Member

    I don’t think connecting Google+ adds the required rel=”author” code to the blog. You can manually add it by placing the following code inside a Text widget.

    <a href="[profile_url]?rel=author">Google</a>

    Replace [profile_url] with your Google+ link.

    <a href="https://plus.google.com/116394575739281318169?rel=author">Google</a>

    Also make sure to add the blog’s URL to the Contributor To section of your Google+ profile.

    Source: https://support.google.com/webmasters/answer/2539557?hl=en

    #1609889

    anaspoke
    Member

    Thank you, but I did the above steps as well. I have put that code in a text section of my profile (under “users”) and my Google+ profile shows my blog in contribute section.

    Ana

    #1609890

    anaspoke
    Member

    Also, I get this error

    Error:┬áMissing required hCard “author”.

    Thanks again.

    Ana

    #1609891

    anaspoke
    Member

    And this one as well, sorry.

    Error:┬áMissing required field “updated”.

    Ana

    #1609893

    a1jesin
    Member

    Whatever you enter in the “My Profile” section is used here – http://gravatar.com/anaspoke

    So you must place that code in a text widget so that it is available in the frontend.

    #1609895

    a1jesin
    Member

    Error: Missing required hCard “author”.

    You’re getting this error because this theme isn’t displaying a byline (eg by Ana Apoke). The Pilcrow theme displays this byline only on multi author blogs.

    Error: Missing required field “updated”.

    This theme isn’t showing any “modified” date for the posts which is the cause of this error. This error doesn’t have anything to do with G+ authorship.

    #1609902

    justjennifer
    Moderator

    @anaspoke- did you follow these instructions for connecting your profile? http://en.support.wordpress.com/google-plus-profile/

    If so, I don’t see the Google+ Author profile appearing under your posts.

    #1609963

    anaspoke
    Member

    Hi,

    Thank you very much for trying to help.

    1. I have definitely connected Google+ profile, I can see that under settings-sharing it says under Google+ “connected as Ana Spoke”

    2. If you click on the Gravatar link above or here http://en.gravatar.com/anaspoke, you can see that I am connected to google (I have also verified email)

    3. “You’re getting this error because this theme isn’t displaying a byline (eg by Ana Apoke). The Pilcrow theme displays this byline only on multi author blogs.” How do I solve this, or do I need to?

    4. Structural test tool still gives me errors.

    Please help and thank you in advance.

    Zhanna

    #1609965

    timethief
    Member

    The Pilcrow theme displays this byline only on multi author blogs.” How do I solve this, or do I need to?

    There’s a single author workaround you can use. See this thread Displaying post author (byline) for Pilcrow https://en.forums.wordpress.com/topic/displaying-post-author-byline-for-pilcrow?replies=6#post-1116264

    #1609974

    anaspoke
    Member

    Thank you timethief!

    The only thing, I am not clear what this means:

    “While logged out of WordPress.com create another username account with a different email address.”

    Am I supposed to create a completely new WordPress user?

    Thanks again.

    Zhanna

    #1609975

    timethief
    Member

    Yes. There has two or more authors for the author byline for any authors to display. So you have to create another username account using a different email address, when logged out of WordPress.com.

    #1609983

    a1jesin
    Member

    @anaspoke Just because your gravatar page links to G+ it doesn’t mean you blog will have G+ authorship. The WP.com blog and gravatar and totally two different things.

    For Google’s authorship to work you need to have a link on your blog which points to your G+ profile. From the Google’s content guidelines:

    Linking your content to your Google profile is a two-step process. First, you add a link from your website or page to your Google profile. Second, you update your Google profile by adding a link back to your site.

    #1609984

    anaspoke
    Member

    Thank you timethief!! It works now!!

    A1 – Those directions are funny, since both steps do exactly the same thing.

    I’m just so happy I can forget about this now! Thanks everyone for trying to help!

    Ana

    #1610110

    zreid
    Member

    Just wanted to take a moment to say thanks to a1jesin !!
    I was having the same problem, but by adding the small text widget at the bottom of my page with the ?author= code I was able to get the problem solutioned! Now I just gotta write write write and get more shares to actually show up in google searches!!
    http://quickmeups.com

    #1610111

    a4aniruddh
    Member

    Even I facing the authorship issue on my blog techandwe.com. The structred data preview tool says, every thing is matching. But search engine, nothing displays.

The topic ‘Google authorship does not work despite connecting Google’ is closed to new replies.