Google Maps

  • Author
  • #1382067



    I’ve tried this question before but got no replies…

    I have 2 blogs where i frequently use google maps to diplay points of interest.

    up until a month ago everything work perfectly but now I can’t get the maps to show in the blog posts.
    I am copying the <iframe> code from maps to wordpress and paste it as instrycted (as I’ve always done) but it does not show in my posts.

    when i look at old posts where it do work I can see that the code is very different.

    Here I have an old post where it works:

    and the code looks like this:

    Here is a new post where it doesn’t work:

    Code looks like this `<br />
    <br /><small>View <a href=”,-122.349887&spn=0.068952,0.07167&source=embed” style=”color:#0000FF;text-align:left;”>Seattle</a> in a larger map</small>`

    Can anyone please help me with this – it’s driving me mad…

    The blog I need help with is



    You have several different fonts in the post that doesn’t work. This makes me think you’ve somehow introduced HTML errors and they might be causing this.

    Go to Settings->Writing and select “WordPress should correct invalidly nested XHTML” and save. Then edit that post, making any change at all.

    Then try re-embedding the Google Map. See if that helps.



    Raincoaster: I tried your solution but no change. The map still does not show.

    I really don’t understand why it transform to a different kind of code than it used to do…

    Is there any other possible solution you can think of?



    Well, staff have been tinkering with themes but that should not have an effect on this. For now I suggest you take a screenshot of the Google map and upload that instead. At least it will look consistent. And maybe overnight someone else has some ideas?



    Hi, I have the same problem and can’t figure out why!
    I thoroughly followed the instructions here:

    But everytime I save the post the iframe code just disappears instead of changing to [googlemaps… ] like it says in the instructions.
    Can’t anyone from the staff give a help on this?

    I’m using the Fresh&Clean theme if that’s of any help.



    If the code disappears instead of converts into something else, are you putting it in the Text editor like the instructions say or the Visual editor?



    Hi raincoaster, yes I am putting it in the Text editor. I’ve been following the instruction word for word! :(
    I’ve tried it a dozen times now even closing the blog and re-opening it.
    I also tried to paste the code in a brand new blank post page but got the same result: the entire <iframe> code gets stripped.
    As far as I know the <iframe> tag is not allowed in posts but the google maps should be some kind of exception.
    It looks as though the exception is not recognized so the code just gets stripped off.



    Well, I’m out of ideas. I am flagging this for staff to figure out.



    Thanks raincoaster.
    I also found this other thread reporting the same problem:
    The frustrating thing is that up to now people say they “solved” the issue not knowing how… which is of little help!
    Hope to get some feedback soon.



    HI stromstrom and forthose,

    I just tested the Google Maps feature and it is indeed working properly.

    What I did:
    I went to Google Maps and decided I wanted directions to the Eiffel Tower.

    When the map popped up, I chose the link icon:

    It gave me two different link options. I chose the second one, and copied it to my clipboard:

    From there, I opened a new post, chose the TEXT editor tab rather than the Visual tab, and pasted the code in. It looked like this:

    When I published the post, the code automagically transformed into a Google shortcode:

    I also tried this with the Zoren theme, which is the theme running on, as well as the Fresh and Clean theme. Both worked fine.

    This is how the map appears:

    There are a number of places things could go wrong:
    1) Copying the first code in the Google map generator
    2) Clicking the button “short URL”.
    3) Possibly, the customize map feature (I didn’t test that)
    4) Copying any other map code
    5) Inserting the code into the Visual rather than Text editor
    6) Modifying the code after it switches to a short code.

    Could those of you having issues review my steps and try to reproduce them, and let me know how it goes? If you’re still having trouble, it would be especially helpful if you could link me to the blog post (you can just save it as a draft or publish privately) so I can see what your code looks like.



    Hi jackie,
    alright, so after trying all the steps you (and the help topic) suggest a dozen times on my work PC I just did the same at home and… TADAAA… it works!
    As a matter of fact I wanted to try another computer earlier but didn’t get a chance.
    I’d like to try again tomorrow on another PC from work just to make sure it’s the PC.
    I have a feeling that rather than that, it could be the connection.
    The work connection goes through some proxy server based in Switzerland (I’m based in Italy) so it could be that the iframe code doesn’t get through to the wordpress servers so it doesn’t get processed somehow.
    I’ll post again tomorrow. It could come useful for some other user in this same particular situation!
    Thanks for caring! ;)



    Hi forthose,

    I would love more troubleshooting on this issue. It could be that you’re right, and when the page reloads to display the correct shortcode, something gets gummed up in the process. I’m not sure if we can fix that easily if that’s the case, but it would be good to know.



    Hi all,
    Thanks for the help.

    For me the problem seem to be Google Chrome. I use this on my work computer (PC) and at home I have a Macbook air where I use Safari.

    So today at work I tried using my work computer but I re-pasted the code in Firefox instead and it worked.

    Very strange…

    I hope this helps others out there who encounter this problem – switch from Chrome as your browser (which is sad because Chrome is by far my favorite)



    Hi stromstrom,
    now I’m really puzzled!
    I used Chrome both at work and home and it worked last night at home.
    So I thought the browser can’t be the problem but I tried changing it here at work this morning anyway. And it worked (IE Explorer)!
    So, just to be sure I tried it on Chrome again and… it works!! =:0
    At this point I really wouldn’t know what to think. There doesn’t seem to be any pattern and – as other users reported – it just seems to magically go on or off.



    That is very strange.

    I used the exact same computer that I’ve used the last times when it didn’t work and today there is no problem when I use Firefox instead of Chrome.

    I’ll try it at home tonight and see if there is any change.

    How can the <iframe…> code transform to 2 different versions?



    Hi stromstrom and forthose,

    If you continue to have problems with this, please save as a draft a post with the non-functioning code, and post the iframe code you got from Google and then the (not working) googlemaps shortcode here in entirety. It would also help to have the address you used to create the map. Essentially, I’d like all the bits so I can try to reproduce it, and if I can spot any obvious places where it’s falling apart, I can let our developers know.


    I’ve got the same problem… Google may have changed something though…

    Original code:
    <iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src=",+Hauts-de-Seine,+%C3%8Ele-de-France&z=14&iwloc=A&cid=15985986045963242350&ll=48.838669,2.308899&output=embed"></iframe><br /><small><a href=",+Hauts-de-Seine,+%C3%8Ele-de-France&z=14&iwloc=A&cid=15985986045963242350&ll=48.838669,2.308899&source=embed" style="color:#0000FF;text-align:left">Agrandir le plan</a></small>

    What’s left:
    <br /><small><a href=",+Hauts-de-Seine,+%C3%8Ele-de-France&z=14&iwloc=A&cid=15985986045963242350&ll=48.838669,2.308899&source=embed" style="color:#0000FF;text-align:left;">Agrandir le plan</a></small>

    It seems it does like my iframe at all!



    Hi tchizbeurgueur,

    Did you see the iframe code transform into a shortcode in your post? Can you send me the link to the post?


    No, it hasn’t transform in the shortcode. It just got rid of the iframe! (private site at the moment).



    I just tried adding your iframe code and it didn’t work for me either. Can you try generating a new code? Also, could you post the address you’re using?

The topic ‘Google Maps’ is closed to new replies.