Need help? Check out our Support site, then

Google Maps shortcode creation failing

  1. I'm having difficulty getting the Google Maps shortcode to work. And yes, I've tried the prescribed method of getting the embed code from Google Maps and putting into the page and letting WordPress figure out how the shortcode should be formatted, and I've tried doing it manually, and both ways fail. I've tried doing it from and, and get the same result

    How can I get maps working on

    Here is an example of what fails, first a simple location:
    <iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src=",+Cammeray,+New+South+Wales&aq=0&oq=451+Miller+st,+Cammeray,+&sll=-25.335448,135.745076&sspn=45.362672,78.574219&ie=UTF8&hq=&hnear=451+Miller+St,+Cammeray+New+South+Wales+2062&t=m&z=14&ll=-33.822205,151.210696&output=embed"></iframe><br /><small><a href=",+Cammeray,+New+South+Wales&aq=0&oq=451+Miller+st,+Cammeray,+&sll=-25.335448,135.745076&sspn=45.362672,78.574219&ie=UTF8&hq=&hnear=451+Miller+St,+Cammeray+New+South+Wales+2062&t=m&z=14&ll=-33.822205,151.210696">View Larger Map</a></small>

    And here is another example of what I want to include on the page, another Google map:
    <iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src=",146.777344&spn=23.552538,39.287109&output=embed"></iframe><br /><small>View <a href=",146.777344&spn=23.552538,39.287109&source=embed">NSW Variety Bash 2012</a> in a larger map</small>



    The blog I need help with is

  2. On my test site, I grabbed the code for your second example directly from Google Maps and pasted it in a post on my site and changed it to the shortcode without problem. But, copying and pasting the code you gave above in my test post, it did not change to the shortcode.

    So you might want to give the following information:
    What OS and browser are you using? (try clearing your browser cache and cookies)
    Are you logged into Google or not when grabbing the code?

  3. Thanks, JustJennifer. I'm using a Mac with Chrome, and logged in to Google. I'll try it on another browser.

  4. Well I just tried it on another browser (Safari), not logged in to Google, and it's still just converted into links, not maps:

    </p> <p><a href=",146.777344&spn=23.552538,39.287109&output=embed">,146.777344&spn=23.552538,39.287109&output=embed</a><br /><small>View <a href=",146.777344&spn=23.552538,39.287109&source=embed">NSW Variety Bash 2012</a> in a larger map</small><br />


    <br /> <a href=",+Cammeray,+NSW&aq=0&oq=451+miller+st,+cammeray,+ns&sll=-22.390714,146.777344&sspn=45.585809,56.513672&ie=UTF8&hq=&hnear=451+Miller+St,+Cammeray+New+South+Wales+2062&t=m&z=14&ll=-33.822205,151.210696&output=embed">,+Cammeray,+NSW&aq=0&oq=451+miller+st,+cammeray,+ns&sll=-22.390714,146.777344&sspn=45.585809,56.513672&ie=UTF8&hq=&hnear=451+Miller+St,+Cammeray+New+South+Wales+2062&t=m&z=14&ll=-33.822205,151.210696&output=embed</a><br /><small>View <a href=",+Cammeray,+NSW&aq=0&oq=451+miller+st,+cammeray,+ns&sll=-22.390714,146.777344&sspn=45.585809,56.513672&ie=UTF8&hq=&hnear=451+Miller+St,+Cammeray+New+South+Wales+2062&t=m&z=14&ll=-33.822205,151.210696">NSW Variety Bash 2012</a> in a larger map</small><br />

    It's definitely saved the screen refreshed, so caching is not the issue. It's in processing by WordPress that it is converted from <iframe>blah blah blah</iframe> to blah blah.

    I've tried it with different themes, too, in case there's involvement with the theme, but it's still happening.


  5. If I go to instead of to get the maps, the following code is generated, but it doesn't display anything on the page:

    <br /> [googleapps domain="www" dir="maps" query="f=q&source=s_q&hl=en&geocode=&q=451+Miller+Street,+Cammeray,+New+South+Wales,+Australia&aq=0&oq=451+miller+st,+cammeray,+&ie=UTF8&hq=&hnear=451+Miller+St,+Cammeray+New+South+Wales+2062,+Australia&t=m&z=14&ll=-33.822205,151.210696&output=embed" width="425" height="350" /]<br /><small><a href=",+Cammeray,+New+South+Wales,+Australia&aq=0&oq=451+miller+st,+cammeray,+&ie=UTF8&hq=&hnear=451+Miller+St,+Cammeray+New+South+Wales+2062,+Australia&t=m&z=14&ll=-33.822205,151.210696">View Larger Map</a></small>

    and what is displayed is just this:

    View Larger Map

    The same with the other map.

  6. That last one is coming up "googleapps" not "googlemaps" and perhaps this forum post will be relevant for you

    Otherwise I'm stumped. I can't reproduce this problem using a PC and Chrome, whether I'm logged in or not to my Google account. I'll tag this for Staff attention, but I hope that perhaps another user might have an idea. Sorry I couldn't be of more help.

  7. FWIW-Looking through the associated discussions using this tag, it seems you are not alone in your problem.

  8. Yeah, thanks JustJennifer. I put in an official request to WordPress support, but 5 days later have not heard anything. I'm surprised that an official, documented function fo WordPress fails in this way. It's really needed for a number of sites I look after.

    Thanks so much for your help.

  9. I finally heard back on this from WordPress support. Apparently if is used instead of, that fixes things. I've tried it once, and it does! Maybe the documentation should reflect that. Well it's good to have something which works. Thanks, JustJennifer, for your help on this.

Topic Closed

This topic has been closed to new replies.

About this Topic