Google Maps/contact details

  • Author
    Posts
  • #1083461

    sbkahler
    Member

    macmanx,

    The map shows up on my blog page if I use my street address without the suite number, as you suggest. I’m wondering why the suite number is an issue for the map, but not for the link from the address to a map (which opens on a different page, of course)? If I don’t use the map, and use the suite number in my address, the address will link to a correct map, in other words. I wish I could have both … the suite number in my address and the map on the blog page!

    Any ideas why the map on my blog page doesn’t work with the suite number included in my address, but the address with the suite number will work as a link to a map (open a map on a new page)?

    Clear as mud? ;-)

    Thanks for your help!

    #1083463

    macmanx
    Staff

    To be honest, I’m not sure yet, but at least we’ve isolated the problem.

    We’re looking into this.

    #1083464

    macmanx
    Staff

    sbkahler, one more thing to try:

    819 E 64th St. Ste 248, Indianapolis, IN 46220

    I think the re-structuring of the address may make a difference.

    #1083467

    Hi macmanx

    The address of my hotel is 31st January Road, Fontainhas, Panjim 403001.

    Although the addresses seem to be the same, the markers are different.

    My hotel is the Mitaroy Goa marker that you see.

    #1083474

    macmanx
    Staff

    Ok, please try this:

    31st January Road, Fontainhas, Panjim, Goa 403001, India

    #1083480

    Nope. Still no luck.

    #1083484

    macmanx
    Staff

    Hm, this is very strange.

    We’re looking into it.

    #1083488

    macmanx
    Staff

    Ok, you’re all fixed up at the moment. Strangely, this works just fine:

    31st January Road, Fontainhas Panjim, Goa

    So, we’ll leave that in place while we figure out what the route cause was.

    #1083489

    Er…still the wrong hotel Macmanx !!!

    My hotels name is Mitaroy, not Leela!!

    I dont understand why its not working…

    #1083492

    macmanx
    Staff

    Well, at least it’s not the middle of the Atlantic Ocean this time.

    Google Maps works off of latitude and longitude. When an address is entered, the get the latitude and longitude and display the marker at that point.

    For 31st January Road, Fontainhas Panjim, Goa: we are getting a latitude and longitude, but it’s apparently the wrong hotel.

    For 31st January Road, Fontainhas, Panjim, Goa 403001, India: Google is giving us a latitude of 0 and a longitude of 0.

    To be perfectly honest, this appears to be an issue with Google’s Map data, as the two addresses are exactly the same. The latter just clarifies a country and postal code, so they shouldn’t be two different hotels, much less one in the ocean and the other on land.

    Unfortunately, the core issue is the data that we’re receiving from Google, and there really isn’t anything that we can do about that.

    #1083493

    If I give you the latitude and longitude of the marker, will you be able to manually add it to the map ???

    #1083495

    macmanx
    Staff

    No, the map only works off of addresses.

    In this case, I recommend unchecking the map in the widget, as the address will still be linked to Google Maps.

    #1083496

    That is really a pity.

    WordPress should allow the address to be verified in different ways…

    #1083499

    macmanx
    Staff

    We are working on that, but for now Google is our only option.

    #1083504

    sbkahler
    Member

    The map has spontaneously disappeared for me. Not only that, but my site is now showing up in what appears to be a mobile version even though I’m looking at the site on a desktop computer (i.e., a full-width, regular-sized desktop computer screen). I’m guessing the two are not related, but I thought that I would check … !

    #1083507

    macmanx
    Staff

    I can see the map and regular non-mobile site at http://thoughttonic.com/

    I recommend clearing your browser’s cache: http://en.support.wordpress.com/browser-issues/

    #1083509

    sbkahler
    Member

    I’m on a different computer now, and not having the same problem. I don’t know what was going on earlier, on that other computer. I have a thread open in the Premium section regarding the mobile version of my site showing up when I would not expect it to do so (i.e., on a non-mobile device with a regular-sized screen and fully open browser window). I’m not sure how that issue may relate to the map not showing up in the same situation. Thanks for all of your help, macmanx!

    #1083510

    macmanx
    Staff

    You’re welcome!

    Clearing your browser’s cache will probably fix it on the other computer.

    #1083588

    cffishing
    Member

    FYI – I had the same type of problem. My map was in the ocean. I have fixed it. I pasted the address into Google mapsand Google reformatted my address a wee bit. I copied their version of the address, pasted it back into the contact address firld, saved, reloaded and now it is good.

The topic ‘Google Maps/contact details’ is closed to new replies.