• Author
  • #586827


    How do I make my gravatar appear on my posts? I’ve looked everywhere, and my jpeg is uploaded on, but my gravatar still doesn’t appear when I post on a wordpress blog. Give me a link to the step by step….



    Gravatars appear on comments on blogs where bloggers choose to enable display them. > Settings > Discussion They do not display on posts or pages. They aren’t meant to.



    Consider putting the gravatar into your blogs sidebar, instructions:


    You can take your gravatar image, upload it to your media library and then insert it into each post as you make them.



    Some themes (such as Twenty Ten) do include your Gravatar on each Post (on permalink pages), but it is theme-dependent, so you’d need to try out some themes to see which ones support it.



    Is there a list of these themes that feature gravatars displaying on posts available to us users?



    Interestingly, I actually am using the Twenty Ten theme (the default theme in WordPress 3.1), and Gravatars do *not* show up on each post (for permalink pages). And yes, I did go to Settings > Discussion > and enabled Gravatars. I have several registered Gravatars, but the Twenty Ten theme does _not_ appear to have the code for author posts that displays Gravatars.

    I found a plugin that will display Gravatars for comments, and that is working. I’m comfortable editing my theme if I can find the code snippet and where it needs to go. I’ve also searched for a step-by-step and not found anything for WP 3.1.


    Before the gravatar will show up on twenty ten, you have to go to users > my profile and enter something into the “about” field and save. Then the gravatar and the text you entered in the about field will appear on the post permalink page at the bottom.


    Also flyboym535i, you are in the wrong forum. For self-hosted blogs you need to be over at http://wordpress.ORG/support/ .

    With self-hosted blogs all you need is a little PHP scripting knowledge and you can put a gravatar at the beginning of each post on any theme. Here we cannot do that because we cannot access the underlying theme files.



    thesacredpath! You’ve done it! I added something in the About field for my user’s profile, and just like magic the Gravatars started working. Thanks!</frustration>


    You are welcome.



    I’m using Choco Theme. It shows my gravatar on each post automatically. No customizing is required. :)

The topic ‘Gravatar’ is closed to new replies.