having trouble hiding a page

  • Author
  • #415524

    i set my new blog up so the home page is static (Welcome to my Blog!) and the other page (Posts) will contain
    the posts. everything is fine except on the top of the Home page are three links; Post, Welcome to my Blog and Home.
    i did use the attributes page to try and hid the “Home” category, but it didn’t seem to work, and I can’t edit the “Home” page because there is no “edit this” at the bottom and it doesn’t show up as a page in the list of pages.
    how do i get rid of the unwanted “Home”?

    The blog I need help with is newgolffundamentals.wordpress.com.



    Are you using this method? (second note)


    yes, and this part worked. i just can’t hide the “Home” icon.


    The “home” tab cannot be hidden because it isn’t a “page” as such. It is the link to the dynamically created main post page of the blog. Some themes have a home/blog/front page tab and some do not. See this blog post for which themes do and do not: http://wpbtips.wordpress.com/2009/05/06/the-home-tab/ .


    I should not say it cannot be hidden. The top navigation can be hidden completely but it requires experience with CSS and the paid CSS upgrade. Each theme is designed by an individual author. Some include home links, some do not, and some don’t include top navigation at all. It is all up to the designer.



    I looked at this earlier and wasn’t sure if he you wanted the whole navigation gone or just the home link. The blog for some reason looks wider then my other blog so them I thought you might have the CSS upgrade already. Now I’m not sure still but, for the whole navigation to be gone the CSS would be,
    #nav .page_item {display:none;}
    There seems to be no way to hide the home button itself without removing the whole navigation bar. Though I did search online and the vigilance theme was updated to be able to remove the home link but until wordpress upgrades the theme options page then it’s not possible on wordpress.com blogs.


    thanks for your suggestions, i’ll give them a try. (for the record, there has been no CSS upgrade.)


    changing the theme worked. thanks for your help!


    You’re welcome.

The topic ‘having trouble hiding a page’ is closed to new replies.