Having trouble linking Facebook account

  • Author
    Posts
  • #985713

    holyspiritcc
    Member

    Hello, we have followed the steps to link our Facebook account so that we can link our blog posts. However, the “publish to Facebook” button doesn’t appear in the “publish” menu. Could you help us? Thanks
    Blog url: http://holyspiritcatholicchurch.wordpress.com/

    The blog I need help with is holyspiritcatholicchurch.wordpress.com.

    #985810

    timethief
    Member

    1. Please try the full reconnect procedure again detailed at http://en.support.wordpress.com/publicize/#reconnecting-facebook including step 3 (removing the FB app), which is probably the most important step.

    2. See also publicize troubleshooting http://en.support.wordpress.com/publicize/#troubleshooting

    #985842

    holyspiritcc
    Member

    When we disconnect, then re-connect to FB, we get this message “You have successfully connected your WordPress.com blog with your Facebook account.” However, the publicize tab never appears in the blog settings.

    #985902

    macmanx
    Staff

    Just to be sure, did you follow the crucial app-deleting step in http://en.support.wordpress.com/publicize/#reconnecting-facebook ?

    #985934

    holyspiritcc
    Member

    Actually, whenever we attempt to “connect” it to FB, it asks us to log in to FB (which we do), but then it comes right back to the settings page and says “You have successfully connected your WordPress.com blog with your Facebook account.” It never gives us the option to configure the FB app.

    #985936

    macmanx
    Staff

    That’s because the app is still installed at Facebook.

    You need to delete it as part of http://en.support.wordpress.com/publicize/#reconnecting-facebook

    #985938

    holyspiritcc
    Member

    It was never installed to begin with, and following those steps just repeats what I already mentioned above.

    #985939

    macmanx
    Staff

    Would you please check your installed apps on Facebook just to be sure?

    #985962

    holyspiritcc
    Member

    Ok, we went in to FB, deleted the app, then added it back again through WordPress. However, the blogs are still not appearing

    #985963

    relisaz10
    Member

    I am having the same problem. Have deleted the app, reactivated, and still nothing.

    #985964

    Ok, we went in to FB, deleted the app, then added it back again through WordPress.

    To confirm, once you deleted the WordPress app from Facebook, did you go to Settings -> Sharing in your WordPress.com blog dashboard, and click “Connect to Facebook”?

    However, the blogs are still not appearing

    Are you referring to published blog posts being Publicized to your Facebook account?

    #985965

    relisaz10
    Member

    I know you aren’t replying to me, but to answer your questions, yes to the first, says it is connected. And no, I’m talking about publishing a new blog after doing all of this, not old ones.

    #985966

    I am having the same problem. Have deleted the app, reactivated, and still nothing.

    Hi relisaz10,

    To clarify, did you mean the same problem being that you try to connect Publicize to Facebook with these steps in Settings -> Sharing?

    Also, can you confirm trying these five steps to troubleshoot Reconnecting Facebook to Publicize?

    #985967

    relisaz10
    Member

    Yes, I have done the 5 steps twice, including deleting the app, logging out of fb, then reconnecting.

    #985968

    I know you aren’t replying to me, but to answer your questions, yes to the first, says it is connected. And no, I’m talking about publishing a new blog after doing all of this, not old ones.

    @relisaz10: Which WordPress.com blog URL are you referring to?

    #985969

    relisaz10
    Member

    relisaz10.wordpress.com

    #985970

    @relisaz10: Thanks. I saw that you just published a test post a few minutes ago. Did it get Publicized to your Facebook wall?

    (For posterity, you can see which one it’s linked to by going to Settings -> Sharing, then click the Set Options link under Facebook when Publicize is connected.)

    #985971

    relisaz10
    Member

    Nope it didn’t. It says it is posting, everything looks like it should and twitter is working fine, but no fb.

    #985972

    @relisaz10: Okay, thanks for confirming, and I’m sorry for the hassle.

    I’ve reported this to our developers to take a closer look. While I can’t give a time frame, I’ll be sure to keep you posted with updates as I hear back from them.

    Thanks for your patience!

    #985973

    justin
    Staff

    @relisaz10:

    Thanks for the patience. I’m looking into the issue for you.

    Can you look under http://www.facebook.com/settings?tab=applications and see if “WordPress.com” still shows up now that you have reconnected?

    If so, can you post another test post or two? You should be able to delete them right after. I would like to collect some additional debugging information and see what error we are getting when contacting Facebook.

    Thanks again,
    Justin

The topic ‘Having trouble linking Facebook account’ is closed to new replies.