HEADER IMAGE ONLY SHOWING ON STATIC PAGE

  • Author
    Posts
  • #1307012

    gnk1969
    Member

    How can I have my header image only on the static page (aka my home page) and not on all the pages.

    The blog I need help with is lifeilead.com.

    #1307324

    justjennifer
    Moderator

    Since Academia (the theme you are using) supports a full-width page template, perhaps you can insert the image in a static home page and not as a “Header”. http://en.support.wordpress.com/pages/front-page/

    Now I see that you’ve posted in the “CSS Customization” forum, so hopefully staff or a forum volunteer with more CSS experience than I will be along to help you soon.

    #1307325

    justpi
    Member

    I can show you how to make it appear on the homepage only, but in my opinion this isn’t correct when the top menu is below the header image (as it would make the menu jump about when you move from the homepage to another page or vv). So I suggest you revert to menu above image first. But if you do this, then you don’t even need CSS to hide it from the rest of the pages: you can follow Jennifer’s suggestion.

    #1307334

    gnk1969
    Member

    Justpi, I can move the menu above the header image and then can you please help me?

    As for jennifers advice I should have mentioned in my initial post that I have tried taking the image off of the header and placing it within the static page, unfortunately when I do this the top half of the image appears and the bottom half, including “empowering leaders of transformed lives,” does not.

    #1307338

    justpi
    Member

    I’m not sure I understand your reply re Jennifer’s advice. Images are never cropped when inserted in the content of a page, so I guess you mean the bottom part of the image doesn’t show unless you scroll down. If that’s what you mean, then a) this depends on each visitor’s screen resolution, b) it’s due to the fact that there’s some empty space above instead of below the image, and you could use CSS editing to remove that space.

    Anyway, to display the header image on the homepage only, add this in the CSS editor:

    #slider-wrap {
    display: none;
    }
    .home #slider-wrap {
    display: block;
    }

    #1307353

    justjennifer
    Moderator

    One other thing you should be aware of is that the name of your site “Life I Lead Inc.” is missing from every Page and Post Title because it appears that you’ve added “Help Line” to the Title box in Dashboard>Settings>General Settings. As a result, you’re missing a crucial piece of information for search engines.

    Perhaps this is intentional, but I thought I would make you aware of it if not.

    #1307355

    gnk1969
    Member

    thank you Justpi! worked great! and justjennifer thank you for that observation, MAJOR help!!! You were both very helpful, justjennifer and JustPi, thank you!

The topic ‘HEADER IMAGE ONLY SHOWING ON STATIC PAGE’ is closed to new replies.