Need help? Check out our Support site, then

Help!! Gallery Thumbnails Pixelated & Blurry!!

  1. evergreendazed


    Just created a gallery using the thumbnail grid option, and the images turned out pixelated.
    My images are 1280px wide, I'm using Safari and Chrome.
    They look fine when I use the mosaic tiles in the WP gallery, but once I switched to thumbnail grid, they turned out pixelated.

    Here's the page in question:

    Any advise?

    The blog I need help with is

  2. sandymcfadden

    Hi evergreendazed,

    Have you tried deleting the gallery and then adding it in again?
    I would start there and see if it fixes things up. Make sure you choose the number of columns you want with the thumbnail grid gallery.

    Let me know if that fixes it up for you.

  3. evergreendazed

    Hi there,

    I have tried that, didn't work.

    My monitor resolutions are 2560x1440 and the larger images don't load properly on both Safari and Chrome.
    This is what appears on my browser:

    My thumbnails (featured images) are the same as my larger images. They're 1200x800 wide, please see this screenshot for my gallery settings:

    The only way for the images to look properly is to make it 3 columns, even 2 columns look pixelated. But then 3 columns would make the images too small, and I don't want that.

    Is there a way to fix this?

  4. evergreendazed

    Problem solved!

  5. sandymcfadden

    I'm glad you were able to get it working. Can you let me know what fixed it so I can keep it in mind or if someone runs across this issue by searching the forums later on?


  6. sandymcfadden

    Thanks justjennifer!

  7. evergreendazed

    Hi sandy,

    It was solved by changing the Image Sizes in the Media Settings.

    Thank you for helping me out! :)

Topic Closed

This topic has been closed to new replies.

About this Topic