Help: Google Sitemap Issues

  • Author
    Posts
  • #905031

    lmdl09
    Member

    Having noticed a recent and noticeable lag in indexing time of new posts by Google, I resubmitted the site map for my blog to Webmaster Tools, which came back with 220 errors and 112 warnings, citing “Invalid XML Tag,” “Missing XML Tag,” and “Incorrect Namespace.” Can someone help with this? I understand that WordPress is responsible for the coding that seems to have created this problem.

    The blog I need help with is ldl100.wordpress.com.

    #905182

    timethief
    Member

    Hello there,
    I have flagged this thread for Staff attention. Please be patient while waiting.

    #905296

    lmdl09
    Member

    Thanks. Will be happy to provide a screen shot of the error/warning results.

    #905300

    macmanx
    Staff

    Yes, would you please take a screenshot of the errors and upload it via Media -> Add New in your blog’s Dashboard so we can take a look?

    #905319

    holipompeli
    Member

    Hi! I have the same kind of problems with the sitemap. My previously well ranking blog has suddenly fallen out of Google. This happened a few days after changing my blog’s theme to a new one. Then I have changed the earlier theme back, but this doesn’t help.

    Webmaster tools shows several warnings as follows:
    “Invalid XML tag This tag was not recognized. Please fix it and resubmit”
    “Missing XML tag This required tag is missing. Please add it and resubmit”
    “Incorrect namespace Your Sitemap or Sitemap index file doesn’t properly declare the namespace.”

    Could you please help – thanks a lot in advance!

    #905320

    limberation
    Member

    Hi, I have 450 errors and 227 warnings for http://teamoyeniyi.com

    I also changed themes then changed back again although that was several days ago and these errors are dated as being detected June 2. Not sure if that is my time zone or yours (USA)

    #905321

    limberation
    Member

    Macmanx, I have uploaded two screen shots as per your request.

    They are called Sitemap Errors and Sitemap Errors2.

    I also resubmitted the sitemap and tested it – also reported errors.

    #905323

    holipompeli
    Member

    I changed my theme two weeks ago and then back to the original one about a week later. The mentioned errors have been detected May 31 by Google.

    Today noticed also these site error messages:
    “Couldn’t communicate with the DNS server.”
    “Request timed out or site is blocking Google”
    “Crawl postponed because robots.txt was inaccessible.”

    Macmanx, I’ll also upload some screenshots via Media soon – do you need separate info on the file names?

    #905324

    lmdl09
    Member

    I have also uploaded a screen shot of the errors as requested. The problem seems to mirror holipompeli’s original message. Could briefly activating a different theme have caused these major glitches?

    #905326

    holipompeli
    Member

    Macmanx, you will now find my screen shot of the errors uploaded. Please let me know, if you need any further info. I’m afraid quite many bloggers have the same problem – really great if you could solve it!

    #905332

    auxclass
    Member

    @macmanx

    There are now 5 screen shots in my media library of captnmike.com for two sites with Google Webmaster tools for Site Map errors in captnmike.com and mumblingmike.wordpress.com

    The files are unattached and all start with “Site-Map” – they are the most recent Media uploads so should be at the top of the list. It looks like many blogs are broken.

    #905338

    macmanx
    Staff

    Thanks for sending those in. We’re looking into it.

    #905339

    beau
    Staff

    Hi everyone — we believe this is related to some improvements we’ve been working on to provide richer information in your sitemaps for search engines. We’re working on a fix right now.

    #905343

    lmdl09
    Member

    Will we be advised as to when to resubmit sitemaps to Google?

    #905344

    beau
    Staff

    Actually, if you could try resubmitting now, we’ve already made one fix to the “invalid XML tag”. The other errors you’re getting from Google are a little misleading, but it’s possible this fix will clean them all up. Please let us know on this thread.

    #905345

    limberation
    Member

    Resubmitted and tested and no change for me. Same errors and same number of errors.

    #905346

    beau
    Staff

    My apologies — I forgot to mention that you need to do something to force your sitemap to regenerate, because otherwise they are cached on our servers. Any of the following will force a refresh:

    1. Publish a Post or Page
    2. Edit an existing Post or Page
    3. Trash/Delete a Post or Page
    #905347

    limberation
    Member

    My sitemap report now says “no errors found”. Good to see a steady resolution.

    I notice we now are submitting (or Google are reporting) mobile and image content, but none are yer indexed. Is this part of the richer information project you mentioned?

    #905348

    limberation
    Member

    Darn auto-correct…….. I meant speedy resolution, not steady

    #905349

    beau
    Staff

    Perfect — that’s great news.

    Yep, the mobile + image content is what we’ve been adding there. Your sites are all fully-mobile accessible thanks to the efforts of our Mobile Team, so we can tell Google about that and they know that your sites are OK to list/show in their mobile results.

    If you’re uploading/attaching images to Posts, then we’re now explicitly including that information in your sitemap as well, although Google seems to do a very good job of finding those either way.

    Hopefully you’ll start seeing a bit of extra traffic on your sites with these changes, some from Image Search and some from mobile devices.

The topic ‘Help: Google Sitemap Issues’ is closed to new replies.