HELP ME PLEASE! Home Page can not be edited

  • Author
  • #2507449


    Hi All
    I have a problem I have been trying for 4 hours to fix.
    I can not figure this out at all.

    My website URL is set as a “Custom Link” and labelled “Home” .
    Because it is a “Custom Link” and not a “Page” I can not edited or customize it – so when you visit my site it states NOT FOUND.

    To add: this “Home” custom link is NOT on my created MENU

    Pleeeeeeeez can anyone let me know how to delete this custom link so my URL can be used on an actual page with content on it.

    The blog I need help with is



    You need to read the set up instructions found here and note “Front Page Template”.

    You have two choices on any blog
    (1) All posts on the front page.
    (2) A static front page and posts on a different page.

    By default the front page of your blog displays all published posts (not pages) in reverse chronological order, with the most recently published post on top. That is for the convenience of your returning visitors who will not be happy to have to click through an About page every time they visit your blog as they come to read your most recently published content. Creating that situation can make some visitors annoyed – so annoyed that they stop following your blog.

    However, if you do not want all the posts to show on the front page, then you can create a static front page called for example “Welcome” for your site and a “Blog” page for all published posts (not pages) to display on in reverse chronological order, with the most recently published post on top.

    To do that create two pages first

    After you do that you go to > Settings > Reading and make the designation change for each of the two page and click “save changes”.
    A static page (select below)
    Front page:
    Posts page:

    The guide for creating a static front page is here

The topic ‘HELP ME PLEASE! Home Page can not be edited’ is closed to new replies.