Help! My blog posts are automatically backtimed.

  • Author
    Posts
  • #2506376

    devlopero
    Member

    Hello, please i need help. I created a new blog recently. Right from my first post i have discovered a problem; whenever i publish a new post, immediately it says “posted 9 hours ago.” What could be the cause of this please? Help me stop this backtiming, its causing harm. Anyone?

    The blog I need help with is oaerys.wordpress.com.

    #2506474

    timethief
    Member

    To confirm your timezone is correct know the default timezone is UTC time. You can reset your timezone here > Settings > General. Select the closest city to you in the same timezone in the drop-down menu you see there and then click “save changes”.

    http://oaerys.wordpress.com/wp-admin/options-general.php

    You can edit posts and change the datestamp and timestamp and click update. These images may be helpful:
    http://en.support.files.wordpress.com/2014/02/publish-immediately-edit.png?w=688
    http://en.support.files.wordpress.com/2014/02/publish-module-change-publish-date.png?w=688

    For editing see:
    http://en.support.wordpress.com/posts/edit-posts-screen/

    #2506478

    devlopero
    Member

    @timethief thanks for your reply.
    I changed my timezone before publishing my last post. When i tried to manually edit the post’s time, the time was correct but then it showed me something like “4:30 PM – 9 HOURS FROM YOU.”
    I hope my problem is clear.

    #2506479

    timethief
    Member

    If you have not been able to succeed then type modlook into the sidebar tags on this thread for Staff help. How do I get a Moderator/Staff reply for my question? https://en.support.wordpress.com/getting-help-in-the-forums/#how-do-i-get-a-moderatorstaff-reply-for-my-question Then please subscribe to this thread so you are notified when they respond. To subscribe look in the sidebar of this thread, find the subscribe to topics link and click it.

    #2506480

    devlopero
    Member

    @timethief thanks, i’ll do that. You have helped me sometime in my former blog. Thanks a lot.

    #2506481

    timethief
    Member

    You’re welcome and best wishes. :)

    #2506634

    bruceallen
    Staff

    Hello @oaerys –

    Is this happening on your blog at oaerys.wordpress.com?

    When you create a new post, is is still happening?

    #2506654

    devlopero
    Member

    Yes @bruceallen it still does. It shows me the correct time in the add-new-post screen but then when I click on the drop-down labelled “NEW DRAFT” or the publish button it is showing something else: ‘+9h from you.’ And when I publish a post it is actually tagged ‘9 hours ago’ My admin time zone settings appear to be correct. Please how do I show you a screenshot.

    #2506655

    The “Site +9h from you” notice is letting you know that you have selected a timezone that is 9 hours ahead of your current computer’s time. You can update the time settings on your computer to correct that offset but that should not be required.

    Now that you have changed your timezone in your blog settings, your next post should be published on your blog at the time you selected on your post in the timezone you selected in your blog settings. If your computer’s time setting does not match your current timezone, you will still see the “Site +9h from you” notice but the post should publish at the time indicated in the timezone for the blog.

    To check this, next time you publish a post, check to see if the time shown for the post matches with what you selected for your blog’s timezone (not for the site offset at the bottom of the calendar). If you’re still having trouble at that point, please let me know the post as soon as you publish it and I will try to help take a closer look.

    #2506661

    devlopero
    Member

    Thank you @designsimply. My computer timezone setting was incorrect. Its all cool now. God bless you.

The topic ‘Help! My blog posts are automatically backtimed.’ is closed to new replies.