Help with Full width Page template on 2012

  • Author
    Posts
  • #1005581

    Okay, so I would like to know how to put the full page width template with the blog posts page? Thanks.

    The blog I need help with is thegoonermonkey.wordpress.com.

    #1005679

    timethief
    Member
    #1005680

    timethief
    Member

    If you cannot locate page attributes go to the Screen Options pull down tab http://en.support.wordpress.com/screen-options/ located in the upper right corner of your Dashboard. It can be used to show/hide modules on some screens and show/hide columns on other screens.
    http://en.support.wordpress.com/modules/#list-of-modules

    #1005701

    Thanks for answering timethief. I have already tried changing the attributes however it wont change when I go to my blog page.

    #1005706

    timethief
    Member

    It’s not page attributes that you change. May I ask some questions for clarity sake? I am using the same theme. I go to “Templates” under Page Attributes and in the drop-down menu box I select “Full width Page template, No Sidebar” and then I click “Update”. It works on my blog so I don’t know why it does not work on yours.

    #1005725

    I have tired that and yet nothing happens?

    #1005726

    I’m sorry, tried not tired.

    #1005730

    timethief
    Member

    Well that’s strange and I’m going to flag this thread so Staff take a look at your blog.

    #1005732

    Okay

    #1005857

    kobenland
    Member

    Hi there,

    I’m sorry that it took us so long to respond to your question.

    To make the plog posts page full-width, just remove all widgets from the Main Sidebar, the content width will adjust automatically.

    #1005860

    jakebeamish
    Member

    Hi all, not sure if it’s ok to hop onto this thread but my problem is very related – I’m using a customised TwentyTwelve theme, and I have a front page that is not my blog feed page. Currently, my front page uses both bottom widget spaces that are available for the theme, and I don’t have any widgets in the sidebar space.
    I would like to be able to leave my blog feed page widgetless, but have my other (connect) page to have a twitter widget. I have tried putting the twitter widget into the main sidebar widget space, but even when I set my blog feed page (…/blog) to Full-Width Template, and my (…/connect) page to Default Template, the twitter widget appears on both.
    tl;dr,
    is it possible to set the blog feed page to Full Width in TwentyTwelve?
    Thanks. My site is http://www.jakebeamish.wordpress.com

    #1005861

    michiecat
    Staff

    Hi jakebeamish,

    If I understand you correctly, you want your “Blog” page to be full width, while keeping widgets on your other pages? I’m afraid the only way to accomplish this is to hide the sidebar from your “Blog” page with Custom CSS, available through the Custom Design upgrade.

    For example, the following CSS should do the trick (it hides the sidebar and adjusts the main column width accordingly):

    body.blog #secondary {
          display: none;
    }
    body.blog .site-content {
         float: none;
         width: 100%;
    }
    #1005862

    jakebeamish
    Member

    spot on!
    Thank you very much for your help x

The topic ‘Help with Full width Page template on 2012’ is closed to new replies.