Hide private pages from menu unless loffed in?

  • Author
    Posts
  • #1009386

    redcornerhk
    Member

    I’m setting up a site for a collaboration project that will have some pages open to the public, some password protected and a few private, for the project workers use only.

    If I add a private page to a menu it works for logged in users and gives a “404 not found” for the public. This is correct but ugly.

    Is it possible in wordpress.com to have the private pages appear on a menu to logged in users, and have the menu item hidden from the general public?

    The blog I need help with is translationintibet.wordpress.com.

    #1009439

    raincoaster
    Member

    You can easily use a Custom Menu to list only the Pages you want, but I warn you this works for Pages, not for Posts, all of which show up on the main blog page. The only way to keep your Posts private is to ONLY categorize them “Private” with no other tags or categories and NOT to include a link to the main blog page on your Custom Menu. Does that make sense?

    #1009448

    justjennifer
    Moderator

    Pages or Posts published as “Private” should only appear to logged in Admins and Editors and not to anyone else, logged in or not.

    http://en.support.wordpress.com/pages/page-visibility/
    http://en.support.wordpress.com/posts/post-visibility/

    Which of your Private pages are still visible when logged out?

    #1009470

    redcornerhk
    Member

    Thanks for the replies.

    @raincoaster.
    Makes sense – but it’s not what i’m looking for.

    @justjennifer
    There’s only one private page at the moment: >> Project Area >> “Stuff for your eyes only” :)

    If I log in and go there, there’s a page visible. If *you* go to that menu item you get a “404 not found.” I want to hide that menu item from people, like you, who are not logged in.

    Having the private pages is good – but I don’t want users to have to remember the URL – I’d like it to appear on a menu somewhere.

    #1009474

    justjennifer
    Moderator

    Technically, I shouldn’t be able to see that Page at all if you have published it as “Private”, logged in or not. Only Admins and Editors of your site should be able to see that page.

    Please check the Publish module for that Page to make sure that the visibility is set to “Private”. If not, make the change and update the Page.

    What I do get when I click on “Project Area” is a place to enter a password, which to me means it hasn’t been published as “Private”.

    #1009507

    redcornerhk
    Member

    Sorry about hiding that page. If you look at the page now there is a menu item ‘private’ that leads to a private page. (so to you it looks broken)

    I want to hide that menu item from people who are not logged into the site.

    #1009508

    justjennifer
    Moderator

    Apparently using a Custom Menu overrides the Page visibility settings. (!)

    For the sake of this experiment, would you please remove any Custom Menu you may have set up. You don’t have to delete the menu, just remove it from being the Primary Menu in the “Theme Locations” Module of the Custom Menu Dashboard.

    #1009509

    justjennifer
    Moderator

    My conclusion following my above comment is that it is not possible to have a Page in the NavBar/Menu that is only visible to logged in users.

    The best you can do is what you have already done, which is to include the Page in the Navbar and then require a password to enter it.

    Alternately, don’t put it in the NavBar/Menu at all and only give the address out to the project workers to bookmark. I would still password protect the Page.

    #1009510

    redcornerhk
    Member

    That’s the conclusion I reached as well :( I was just hoping someone would point out a feature I’d missed.

    Thanks for the time you’ve taken on this – much appreciated.

    #1009511

    justjennifer
    Moderator

    You’re welcome and thanks for teaching me something I didn’t know before!

The topic ‘Hide private pages from menu unless loffed in?’ is closed to new replies.