Hiding comments, author, date of post on all content

  • Author
    Posts
  • #823803

    I am using the Elegant Grunge theme, and am trying to figure out how to not show the “leave a comment / posted in…” at the bottom of posts, as well as hiding all of the comment options on pages. I am using this as a business site, not as a blog, so none of those things are relevant to what I want people to see.

    I have the upgrade, so if there is a quick fix I can add to the stylesheet editor, that would be great.

    Thanks for any help!

    The blog I need help with is dancefloormayhempr.com.

    #823961

    timethief
    Member

    You don’t need CSS editing to disable comments. This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    We can also override the default settings and enable or disable future comments on any post or page.
    However, depending on the theme when we close comments a phrase like “comments closed” or a similar phrase may appear and if so, then it can only be removed or hidden by CSS editing after purchasing a custom design upgrade.

    #823983

    I have tried that in the discussion settings, but it is still showing up. My website is:
    http://dancefloormayhempr.com/

    I do have the custom design upgrade, so any tips on css to clean up the theme would be awesome.

    #823986

    The options in discussion settings are the defaults, that will affect any future posts you create but not already existing ones. Did you try disabling comments on the already existing post?

    #823988

    Yes, I tried to disable comments on the already published post. I also want it hidden on Pages. For instance, this Page has a comment box which I do not want:

    http://dancefloormayhempr.com/what-we-do/

    #823990

    I do have the custom design upgrade, so any tips on css to clean up the theme would be awesome.

    I see that http://dancefloormayhempr.com/ is currently using the Elegant Grunge theme. It’s meant to be a little “grungy.” :)

    You might start by adding some content too see how the theme looks in context and then go from there.

    #823997

    That was odd, so I deleted the old pages and re-created them, and that did fix the comment issue.

    Will play around a little more, as I am looking to suppress the info at the bottom of the theme now.

    #823998

    Looks good! If you find one that isn’t working as expected, post the link to it and I’ll check it out to see what I can find.

The topic ‘Hiding comments, author, date of post on all content’ is closed to new replies.