Home Page Won't Load on Fire Fox

  • Author
    Posts
  • #1116063

    johnliming
    Member

    My blog, AMERICAN LIBERAL TIMES, loaded nicely onto firefox for weeks and today it simply quit.

    I get the little circle going back and forth from “connecting” to “waiting” and back to “connecting” again and again and nothing else happens.

    I am running with the WP pro bundle and I was using a template called “Contempt” which I loved and which worked well for a long time – – I have since switched to “Quintus.”

    I uninstalled the firefox and installed it again but nothing changed.

    I keep all my computer discs degragged and clean and I keep my cache cleared and it has always worked for me until today when it suddently stopped loading the blog on Firefox.

    I must add that the blog works great on both Internet Explorer 9 and Google Chrome.

    Is anyone else having similar problems and is there any advice that you might be able to give me?

    I would be so sincerely appreciative.

    I currently have firefox uninstalled but I will be willing to put it back up if there is something that someone can tell me that might make the blog work again.

    My blog is currently:

    americanliberaltimes.com

    Thanks a bunch for listening.

    Respectfully yours,

    John

    The blog I need help with is americanliberaltimes.com.

    #1116184

    rachelmcr
    Staff

    Your blog loads just fine for me in Firefox, and it looks the same as it does in Chrome. I don’t know why it won’t load for you, but it looks like it isn’t an issue with the blog itself.

    #1116185

    timethief
    Member

    Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    Try with all browser extensions or add-ons temporarily disabled.

    Try enabling HTTPS: http://en.support.wordpress.com/https/

The topic ‘Home Page Won't Load on Fire Fox’ is closed to new replies.