Host has disabled the socket connection

  • Author
    Posts
  • #135130

    nemede
    Member

    Error from last API Key attempt:

    Your blog was unable to connect to WordPress.com. Please ask your host for help. (transport error – could not open socket: )

    Is there a way to use officially plugins without an API Key?
    Because I get this error message every time I insert my key.
    My host says they have disabled socket connection and will never enable it.

    ~neme

    edit: and which socket has to be enabled for the wp_stats and the askimet addon?

    #135328

    timethief
    Member

    I’m sorry but the API key is required to use the stats plug-in. I believe that if you look in the forum searchbox you might locate what you are looking for but I cannot be sure of that. If you don’t then you can contact staff by emailing support@wordpress.com

    #135329

    nemede
    Member

    not the key is the problem, the connection to wordpress.com through the socket is the problem because my hoster has disabled socket connections

    :(

    #135330

    timethief
    Member

    Well then what do you think we volunteers can do for you here?
    https://en.forums.wordpress.com/search.php?q=API+key+stats+plugin

    #135331

    nemede
    Member

    It would be nice, if you could tell me if there is another way to enable the plugin ^^

    #135332

    timethief
    Member

    There is no other way that I know of. On my own hosted wp install I simply provided the API key and the stats program was up and running.

    #135333

    nemede
    Member

    because your host has socket connections enabled

    i will send an e-mail to wordpress.com :/

    thanks

    ~neme

    #135335

    timethief
    Member

    I’m sorry I couldn’t be more helpful. :(
    Best wishes for a happy ending.

    #135352

    nemede
    Member

    the support team says:

    Unfortunately you can’t use them if your host doesn’t allow you to open sockets to other servers.

    Sorry,
    Nikolay.

    #135353

    timethief
    Member

    Thanks for returning and for sharing the answer with us.
    I’m sorry you went through all this frustration. :(
    Will you please mark this thread as “resolved”?
    Best wishes for better days and happier endings.

The topic ‘Host has disabled the socket connection’ is closed to new replies.