How about having WYSIWYG?

  • Author
  • #1073314


    Really annoying system here…I post up some text in a post and have a paragraph break but when I view the post the paragraph breaks are gone.

    When I fix that, something else changes.

    Can you PLEASE have a WYSIWYG system so I stop wasting time on this?

    The blog I need help with is



    You do have WYSIWYG editor on your post/page editor
    – You should see a “Visual” Tab on the top right of the editor box.
    (If you don’t see it, please say,)
    – the wordpress,com;s WYSIWYG is somewhat clumsy at times,
    like most WYSIWYG for html editors.

    -When using the visual mode use {ENTER} for paragraph breaks and
    {SHIFT-ENTER} for regular line breaks.



    Before typing in the Visual editor, always make sure the Format tool (row 2 tool 1) is set to Paragraph.



    On my document I’ll have some phrase in bigger type and in a different colour to the main document. That will be, e.g. in “Heading 2”.

    If I move the cursor elsewhere and select “Paragraph” I might, for instance, lose the bigger type and different colour for that particular phrase.

    And say that I see that there are 3 spots where there should be a paragraph break…and I fix two of them. I later notice that I missed one…so, I’ll fix that one…and find that the other 2 have reverted to how they were before.

    This is SO frustrating! Why can’t MY choices stay in force for the document? Why do I keep have to FIGHT the site’s preferences? Why does the site change MY preference to its preferences?

    How do I fix this?

    I always copy documents into Word Press using the Visual mode. I don’t see why changes I implement just don’t stay put!

    I do do use “Enter” to make paragraph breaks. Like I say, they stay enforce if they revisit the document to make further changes…and they should, I think.



    Use the Text editor to edit fonts and such.



    Never copypaste from sources such as Word directly into the Visual editor. Word isn’t designed for that: it introduces wrong code that messes things up. Use the “Paste from Word” tool, or paste into the Text editor then switch to Visual for additional formatting.



    I thought I’d solved this problem…well, it seemed to work…temporarily…until now!

    I’d copy the document to another site and work on it there. Then once it was alright, I’d paste it here. That seemed to fix the whole paragraph space issue…i.e. if there was no paragraph space where I was working on the document at another site, no amount of paragraph spacing here (generally) would introduce a paragraph break.

    That sucks…as in if I introduce a paragraph space at THIS site, it SHOULD stay there! It doesn’t.

    And now, for some reason, after this solution – of sorts – it now doesn’t seem to be working…the same issue of paragraph spaces is starting again. Perhaps this has to do with me editing the document at the other site and trying to introduce those changes here.

    All very annoying. Just wasting my time with nonsense.

    I’m guessing the ‘solution’ is to make all the modifications I want to the document in one go at the other site and then introduce that document to here. The thing is, it takes me some goes to get the document right.



    Why not simply create the post in Windows Live Writer?

The topic ‘How about having WYSIWYG?’ is closed to new replies.