Need help? Check out our Support site, then

How can I change the font size of just 1-2 words in the middle of a paragraph?

  1. I use Windows Live Writer to compose my blog posts. In it, I can adjust the font size for any words or letters I choose to make different from the body of the post. In the past, all font size changes I have made when composing my post show up correctly when I publish my post. Today I composed a post, and when I uploaded as a draft, all the fonts were changed to the original font size. When I looked at the buttons at the top of the post editor, there were buttons to make the font bold, underlined, etc but no button to change the font size. What happened? i am super frustrated!
    Blog url:

  2. The Visual editor never had a button for font size. To change the size you need to add coding in the Text (=code) editor. See here:

  3. Any ideas as to why the changes I make to font sizes when composing my blog post in Windows Live Writer are being removed when I upload to WordPress? When I googled this problem, I found another person who said they are having the same problem, starting October 16. I've never had any problems with this before now either! One of the main reasons to use Windows Live Writer to compose blog posts is to be able to change font sizes, etc without having to know how to write code.

  4. Sorry, no idea: I don't use Live Writer. Perhaps someone else will answer this question.

  5. I have discovered something about this problem - it seems to be the editor in WordPress that is causing the problem. If I compose my post in Windows Live Writer and then publish directly to the blog, the font changes I made are retained upon publishing. But if I upload the post as a draft to my blog, the font changes are erased and all font reverts to the default. If I open a previously published post in Windows Live Writer and make changes to the font and then publish directly to the blog, the changes are retained, and it works perfectly. If I open a previously published post that has font changes in it but I open it in the WordPress editor (just click edit at the bottom of the post), then the font all reverts to default. So, anytime any post goes into the editor on my dashboard, any font changes I have made are erased. Why is this happening? Can it be fixed?

  6. Thank you for the detailed report. I have flagged this thread for Staff attention.

  7. Would you mind providing links to:

    - one or two posts where your formatting is being stripped
    - one or two posts where your formatting is still there

    Thanks very much.

  8. Actually, now that I have figured out that I can open my posts with Windows Live Writer, fix the formatting, and then publish directly to the blog without any changes being made, I have fixed the formatting in all my posts. Here are the links to 2 posts in which I changed the formatting. The changes aren't huge. Just some underlining and a few places where I made the font larger. If I open one of these posts in the editor in WordPress, though, it will remove the underlining and change all the fonts to the default size. Also, if I have a list of bulleted items, and i want a space after it before the next paragraph, when I open it in the editor, it will remove that space. But I can also correct that by opening the post in Windows Live Writer, fixing it, and then publishing directly to the blog. It's weird. I could always just publish directly to the blog except that I want to be able to add a featured image and an excerpt to each post, which I have to do in the editor. Oh, another thing the editor changes is any font colors that I have changed. It puts them back to default as well. Anyway, here are the links. Thanks for your help!

  9. Hi there, thanks for the links.

    I copied one of your posts on a test site but the extra formatting is not being stripped out when switching back and forth between the Visual Editor and the Text editor, or after adding an exerpt and publishing the post.

    For example, here is some of the code that stays on the post:

    <br /> <span style="text-decoration: underline;"><span style="color: #0000ff; text-decoration: underline;"><a href=""><span style="color: #0000ff; text-decoration: underline;">HERE</span></a>.</span></span>

    There was an update yesterday that may have solved this issue. Would you mind please clearing your browser cache to ensure that you're using the latest version of the Visual Editor, and then trying a new post through Windows Live Writer? Let me know if you still have any issues with formatting being stripped, and please provide a link to the post if you are.

    Thanks very much!

  10. Here is a link to one of the same posts I gave you last time. I opened it in the WordPress editor, and updated it. You'll notice that the text that I have in bold was in, I think, 14 pt font size before but now it is back to the default font size of 10.5 because I opened it in the editor. I left it that way so you can look at it.
    Thanks for your help!

  11. Hi,
    Interesting post. I am plagued by the same issue. I write up my blog in Word and then use the paste from Word function within the editor to post my blog. The different font sizes remain whilst in the paste mode, but once I press Insert on the paste from Word window, the different font sizes get converted to a singular one within the editor prior it being posted on to the blog (where same issue persists).

    As suggested above, I updated my editor today, and still the problem persists.

    Any help would be greatly appreciated as its rather irritating to have to do all the extra work to format, only to find it wont work.

    Appreciate any support.


  12. rawelsingh, did your formatting used to be retained when you copied from Word into the editor? Just wondering. Also, how do you update your editor? Just by emptying the internet cache or is there some other way? Thanks.

    Also, when I was searching for info to help with this problem on the internet, I encountered a comment made on a tech blog by somebody else with this same problem - that formatting done in Windows Live Writer was no longer being retained upon uploading to WordPress. She said she started having the problem on October 16, 2012, which is probably about when it starting being problematic for me as well, although I can't pinpoint mine with as much accuracy. Just thought I'd mention that.

  13. Thanks for the quick response. I have tried it two ways; one by copying and pasting the word document directly to the post, and second by copying to the clicking the editor In the latter case it comes correctly up to this stage but when I click insert, the post in both cases shows only one size of the font, as in the former case.

  14. rawelsigh, what I meant to ask was whether you were previously able to format your posts using Word but are now experiencing this new problem or have you always had this problem?

    Windows Live Writer used to work perfectly with WordPress - formatting done in WLW was always retained upon publishing. So the problem I am having is a fairly recent occurrence - it began within the last month.

    kathrynwp, I thought I would let you know that I use Internet Explorer with Windows 7, in case that makes any difference.

  15. I have always had this problem. Thanks

  16. rawelsingh - web-based content management systems like WordPress are not meant to have text pasted from rich-text applications like those meant for word-processing, such as Word. It's best to paste from plain text and add your formatting in the editor. Alternatively, there is a "paste from Word" button you can use in the editor:

    Windows Live Writer is specifically designed for working with blogging systems.

    If you need further assistance, please start a separate thread, since your issue is not related to this one.

    fhelessons - I am continuing to look into the Windows Live Writer issue. Thanks for the additional example and details.

  17. Hi fhelessons - if you don't mind, let's test this with a smaller post to simplify the troubleshooting process. Could you please create a very short post with just one or two paragraphs. Create one version of the post where you go directly from WLW to WordPress and don't make any edits. Then create a second post with the same content, where you do edit the post in WP and the formatting disappears. Please send links to the two posts so I can have a look. (You can make the posts drafts if you want, as long as that has the same effects on the formatting as publishing.) Thanks!

  18. Thanks for your help! I don't know if making the posts drafts will work because if I open the editor to view them, the formatting is stripped. So they are both published on my blog.
    Here is a link to the post that I published directly from WLW to the blog without going through the editor. It still has all the formatting:
    And here is a link to the post when I ran it through the editor. All the formatting (except for where I made it bold) is stripped.

  19. Thanks very much for these. I'm investigating further and will keep you posted.

  20. Hi! I just wanted to let you know that I figured out that I can preview a post from the dashboard without opening it in the editor. So I deleted the posts that were published on my blog and created 2 new ones that are just drafts. One of them I opened in the editor and one I did not. Thanks for your help!

  21. It appears my problem has not been understood, which is like this. I compose the posts in Word using two font sizes , size 14 outside and size 10 in the parenthesis, in the text. When I copy to Post, it initially comes out as such but on clicking 'View Post' the result shows only size 14 including in parenthesis. The result is the same if I first post using the 'Paste from Word' path. I need help on how to maintain the two font sizes in the final post. Thanks.

  22. Hi rawelsingh - since your issue is completely different than the Windows Live Writer one, could you please start a new thread as I mentioned above? It'll allow folks to help you more efficiently, rather than getting lost in this already very long thread. Thanks very much.

  23. I will be grateful for guidance on how to start a new thread.

  24. rawelsingh - from your dashboard, click on "help" in the upper right-hand corner. Then click on "get help". Choose a category, and then click on "contact our happiness engineers". Follow the prompts from there with your question.

  25. To start a new thread, navigate to the most appropriate forum for your question, and then click "Add new" at the top. For example, if the general "Support" forum is most suitable, you can start a new thread here by clicking the "Add new" button at the top of the page:

    It looks like you've already figured this out. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic