How can I disable comments, and stop comment box from showing up?

  • Author
    Posts
  • #589198

    gorebaptist
    Member

    I have gone through each page and disabled comments, but still people can leave comments, and I want to get rid of that option completely.Can someone clearly spell out what I need to do?
    Thanks in advance

    The blog I need help with is gorebaptist.wordpress.com.

    #589299

    For future posts and pages, go to settings > discussion and you can turn off comments there, but that will not turn off comments for already published posts and pages. To do that, you will need to either do each one individually from the “discussion” module in the post and page editor, or use the bulk edit functions on the post and page listing pages.

    http://en.support.wordpress.com/posts/edit-posts-screen/
    http://en.support.wordpress.com/pages/edit-pages-screen/

    #589411

    gorebaptist
    Member

    Thanks for that. I know how to edit pages, but I can’t for the life of me find the discussion module. I have gone to ”Settings” on left hand side, clicked on ‘discussion’, but what from there?

    #589412

    macmanx
    Staff

    When editing a post or page, click the “Screen Options” tab near the top-right and make sure that “Discussion” is checked.

    #589414

    gorebaptist
    Member

    Oh my gosh – found it! Finally!! Rediculous!

    #589417

    For some reason in the page editor after the latest update, the discussion module was unselected by default.

    #589743

    simsonic
    Member

    Nicely done MacManX!

The topic ‘How can I disable comments, and stop comment box from showing up?’ is closed to new replies.