How can I get my Widgets to appear in Twenty-Twelve?

  • Author
    Posts
  • #1007985

    martlove
    Member

    I just switched Themes from Twenty-Ten to Twenty-Twelve. I can’t get my widget sidebars with my links to appear, even though my dashboard says they are visible.
    Blog url: http://martlove.wordpress.com/

    The blog I need help with is martlove.wordpress.com.

    #1008116

    martlove
    Member

    Now I have the first widget area working, but the second one remains invisible. Anyone have any ideas how to make it appear?

    #1008118

    martlove
    Member

    Update: I was able to put most of the links and widgety things in my sidebar, but what are called the first and second homepage widget areas don’t appear. I have the first page designated as a static home page. It doesn’t matter a lot, but there are a few more widgets I’d like to add, and I can’t figure out why it doesn’t work.

    #1008119

    raincoaster
    Member

    Have you checked your post formats? Are you using blog posts or asides, etc</

    #1008120

    martlove
    Member

    I’m not sure what you mean, but I don’t think so. I’m just trying to add a few widgets in the extra widget areas that are supposed to be available in Twenty-Twelve. They don’t appear on my page.

    #1008127

    I am trying to do the same thing with widgets in 2012, let me know if you figure it out! Having trouble getting any to appear

    #1008135

    martlove
    Member

    I decided to try another theme. I think I found one where the widgets all show up.

    #1008136

    Hi martlove and gettingitwritedk,
    I’m using Twenty Twelve for one of my blogs and have widgets showing up. Are you using the correct widget area?

    My blog doesn’t use a homepage (yet). My widgets are added to the Main Sidebar and I use the Default Template page attribute. They show up fine.

    Give that a try…

    #1008139

    martlove
    Member

    Thanks for the suggestion, sanctified brother, but I’ve already switched Themes, although I may try Twenty Twelve again later. The one I’m using now is working really well. I suspect the problem may be that my computer is ancient, and maybe Twenty Twelve didn’t like it.

    #1008140

    justpi
    Member

    No, that’s not the problem. If you open the First or Second Homepage Widget Area you’ll see this note:
    “Appears when using the optional homepage template with a page set as Static Front Page”.
    Is it clear to you what this means?

    #1008141

    martlove
    Member

    It seems to be saying that those widget areas won’t appear unless you’ve designated homepage as static, which I thought I had. Unless I’m missing something somewhere, which is possible.

    #1008143

    justpi
    Member

    Yes, you’re missing something. Merely setting a static page as your front means just that: the blog front will display that static page instead of your latest posts. To make that page display the alternative widget areas instead of the regular sidebar of the theme, you need to edit it and select the Homepage template instead of the Default template (from the Template pulldown in the Page Attributes module).

    #1008148

    martlove
    Member

    Thanks, justpi. I think I get it now. Right now I’m using a different theme that doesn’t have that Template pulldown, but if I go back to Twenty Twelve, I’ll know what to do. I’m still trying to find the right theme for my blog. Thanks again.

    #1008149

    justpi
    Member

    You’re welcome.
    In my opinion, there’s no reason for you to go back to 2012: there’s nothing particularly interesting about it.

The topic ‘How can I get my Widgets to appear in Twenty-Twelve?’ is closed to new replies.