How can I shorten the wait times.

  • Author
    Posts
  • #2117857

    Hi there!

    Like I said, our developers are looking into it. I do need a little bit more information from you though so we know where to look.

    First, does this happen at a certain time of the day? Like, you usually write your blog posts on your lunch break and this always happens then?

    Second, I need some information about a specific asset that’s loading slowly. To get this, open a page you’re having trouble loading in your browser. Then open the Network tab as described in these instructions.

    http://en.support.wordpress.com/browser-issues/advanced-browser-troubleshooting/#http-headers

    Once you have the Network tab open, refresh the page.

    You’ll want to look for anything that’s taking a long time to load, or is failing. Failures will tend to show up in red. In Chrome, you can then right click (or Ctrl + click) on the URL path on the far left and select “Copy link address.”

    Lastly, I need your HTTP header for that asset. Fortunately Chrome has made this pretty easy. In the same place where you copied the asset URL above, right click on the asset, and select “Copy Request Headers”. Paste those in here. Then go back to the asset, right click, and select “Copy Response Headers”.

    #2117860

    leisureguy
    Member

    I fear I didn’t do this right. First, it’s Firefox where I have most of the difficulty and where I blog. Second, I did find and open the window, then clicked (on the WordPress classic edit page) “New post” and was rewarded with about a 1-minute wait at s0.wp.com and then another 1-minute wait for s1.wp.com. I think screen-grabbed what was in the inspection window. It was an HTML document and not the network document, so I imagine it’s useless. I’ve tried a couple of times since, but now it’s loading quickly. I’ll continue trying until I can capture another slow-load instance.

    I blog now and then throughout the day (I’m retired) and the slowdown occurs at all hours.

    Let me see if I’m doing right:

    1. I open (say) “all posts” from the dashboard. That reveals all posts.

    2. I open the Network console.

    3. I click “Add new” and hope that this will be a slow load. If it is, when loading is complete, I then click “show in separate window,” maximize the window, and screen-grab the printout.

    4. Since I’m doing this in Firefox, not Chrome, I do not understand what you mean by “asset”. Is an asset any individual line on the Network list?

    Sorry to be so dense.

    #2117866

    Sorry about that! You’re not dense; I should have given you directions to do that in Firefox.

    In Firefox, you can open the Network tab through the menu at Tools > Web Developer > Network. Then visit one of the pages you’re having trouble loading.

    In the Network pane at the bottom, every line is an ‘asset’. In the Domain column you’ll see something like ‘s1.wp.com’ and in the File column you’ll see something completely unintelligible. We need that unintelligible stuff ;)

    You can grab the unintelligible stuff by right click on it and selecting “Copy URL”.

    Then we also need the HTTP headers for this asset. If you click on the line with the URL you copied, a pane will open on the right. Select the Headers tab. Now if you drag the top of the Network panel up, you can extend the pane so you can see both the request and response headers. Make sure both sections are ‘open’, take a screenshot of those, and upload it to your Media Library.

    I hope this helps clarify things. Let me know if you have any questions, I know getting this type of information can be daunting, but it will really help us be able to figure out what’s going on here.

    #2117867

    leisureguy
    Member

    Okay, I hope this is useful. The first batch I started after it was becoming clear that it would be slow, so I missed the first 10 seconds or so.

    The second was an attempt to load this very page, which was hung up so long in Chrome that it had to be reloaded. The screengrabs are from Firefox though, just to see what happened.

    I have compressed the screenshots into a zip file. I do now see how to attach a file, but you can download it from here: https://www.mediafire.com/?vayx06uwyr6qz5c

    #2117871

    Thanks for that information! I’ve passed it on to our developers.

    #2117872

    barry
    Staff

    Hi,

    In one of your first replies, you mentioned:

    “My IP is 2602:306:bcdc:92e0:11ab:db83:97d0:7544”

    This is an IPv6 IP address, and I suspect the problem stems from that. Not many websites support IPV6 today, but both sX.wp.com and fonts.googleapis.com do. We have heard some other reports about connectivity issues from AT&T to various IPv6 destinations and are currently troubleshooting. For now, I would recommend disabling IPv6 in your operating system (OS X) under System Settings –> Network –> Advanced –> TCP/IP –> Configure IPv6 (off).

    Hopefully this resolves the issue for you, but if not, please let us know.

    #2117873

    leisureguy
    Member

    Wonderful!! We are indeed using AT&T U-verse.

    When I go to the Configure IPv6 in OS X Yosemite, I see 3 options:
    1. Automatically
    2. Manually
    3. Link-local only

    There is no “off” as such, but I’m choosing Link-local only and will let you know.

    MANY thanks!

    #2117874

    leisureguy
    Member

    It’s working!! What a relief!

    Thank you so much for really solving the problem and not blowing it off. I can’t tell you what a difference it makes.

    #2117876

    I’m so glad everything is working for you now! Thanks so much for bearing with me while we worked through everything. :)

    Let me know if you need help with anything else.

    #2117877

    leisureguy
    Member

    You’re welcome, and I greatly appreciate having you take the problem seriously and work at it until the source was identified so a solution could be found. It may well be that others are encountering this and have been thinking, “Well, that’s just the way things are,” so I hope the problem and fix can appear in some FAQs about “Very slow connection times.”

    I can’t tell you what a relief it is to have the WordPress site and tools once more responsive.

    #2117878

    I’ll definitely add a note about IPv6 to our troubleshooting document. Thanks for suggesting it!

    I am so glad WordPress is working for you again. It is so frustrating when something like that happens..

The topic ‘How can I shorten the wait times.’ is closed to new replies.