How do I disable automatic post changes?

  • Author
    Posts
  • #1947579

    I use the text editor to edit my posts. Most of the time when I come back to edit a post, the post has additional
    tags, some of the ‘>’ and ‘<‘ signs are converted to ‘>’ and ‘<‘ respectively and the ‘”‘ characters are converted to ‘"’. How do I stop this from happening so wordpress honors the code I’ve written rather than messing up my posts?

    The blog I need help with is dreadedsoftware.wordpress.com.

    #1947736

    kokkieh
    Staff

    some of the ‘>’ and ‘<‘ signs are converted to ‘>’ and ‘<‘ respectively and the ‘”‘ characters are converted to ‘”‘

    Sorry, but I don’t see any difference here between before and after. Might I suggest you paste a part of the actual code before and after here. Post between backticks or code tags so we can see the actual code.

    Note that certain types of code isn’t allowed and the software automatically strips it out if you use it. http://en.support.wordpress.com/code/

    #1947808

    I start with the following:
    [code language="scala"]
    this test < that test
    that test > the other test
    println("a string")
    [/code]

    I close my browser and come back to my post and see:

    <p>[code language="scala"]
    this test < that test
    that test > the other test
    println("a string")
    [/code]

    I close my browser and come back to my post and see:

    <p>[code language="scala"]

    this test < that test

    that test > the other test

    println("a string")

    [/code]

    This effect compounds indefinitely. Its incredibly annoying.

    #1947822

    kokkieh
    Staff

    I’m unable to replicate this issue on my blog, so the error is not in the code you posted here. I’ll tag this for staff to follow up. They might notice something we don’t. Please be patient while waiting for them to respond.

    BTW, it doesn’t seem to make a difference whether I use the text or the visual editor – the code-shortcode works the same in either editor.

    #1947823

    druesome
    Staff

    Hi there! I’m not quite seeing what the problem is because some of the code you provided had disappeared. Can you please surround your code in backticks? Thanks!

    #1947845

    Forgot the backticks:

    Start with:

    [code language="scala"]
    this test < that test
    that test > the other test
    println("a string")
    [/code]

    After updating, leaving and coming back find this:

    <p>[code language="scala"]<br />
    this test < that test<br />
    that test > the other test<br />
    println(&quot;a string&quot;)<br />
    [/code]</p>

    After updating leaving and coming back find this:

    <p>[code language="scala"]<br /><br />
    this test < that test<br /><br />
    that test > the other test<br /><br />
    println(&quot;a string&quot;)<br /><br />
    [/code]</p>

    After updating leaving and coming back find this:

    <p>[code language="scala"]<br /><br /><br />
    this test < that test<br /><br /><br />
    that test > the other test<br /><br /><br />
    println(&quot;a string&quot;)<br /><br /><br />
    [/code]</p>

    The issue compounds itself indefinitely.

    #1947851

    druesome
    Staff

    Hi there!

    I went in and edited your post and pasted the code in Text and Visual mode, but was unable to replicate the compounding effect you described after many tries. Can you try copying this text:

    [code language="scala"]
    this test < that test
    that test > the other test
    println("a string")
    [/code]

    And pasting it into the same post and see if the problem continues? Thank you!

    #1947875

    The problem is still there, if you go into the post editor and select the “Text” tab you will see the problem. Here is what it looks like pasted into the forum (some of the issues don’t show here but show in the editor):

    [code language="scala"]<br /><br />
    this test < that test<br /><br />
    that test > the other test<br /><br />
    println(&quot;a string&quot;)<br /><br />
    [/code]

    #1947879

    druesome
    Staff

    Hi there,

    That’s very strange. If you notice the code that I pasted in your post, it managed to stay the same while yours continued to display the compounding effect. Did you happen to paste the code in Visual mode? If so, can you try pasting it in Text mode instead?

    It might also help to copy the code and paste it into a text editing software such as Textpad before pasting it into the post editor. Let me know if that helps. Thanks!

    #1947882

    I pasted it in text mode. I have had success with using an outside text editor in the past but, that’s an added layer of complexity I’d like to do without.

    #1947883

    druesome
    Staff

    Hi there!

    I’ve asked our developers to take a look at the issue, and I’ll give you updates as soon I hear back from them. Thank you!

    #1947884

    druesome
    Staff

    Hello again,

    The problem appears to be happening exclusively in the WordPress.com post editor. That post editor is a work in progress, so I would suggest publishing your posts through your blog’s admin panel instead.

    https://dreadedsoftware.wordpress.com/wp-admin/post-new.php

    Let me know if you’re still running into the same issue. Thanks!

    #1947885

    1tess
    Moderator Emeritus

    So there have been many documented problems with this

    post editor. That post editor is a work in progress,
    so I would suggest publishing your posts through your blog’s admin panel instead.

    So would it not be more user-friendly to warn WordPress.com users that this experimental “post editor” is not a finished and reliable product for use by the average user?

    Odd things have been happening with it, without warning. Would it not be more user-friendly and useful to ask for volunteers to test it out and provide evaluations about how it functions before inflicting such, what? problems, lost work, possible damage to sites of unsuspecting users?

    #1947888

    druesome
    Staff

    @1tess: I understand the frustration this could cause but rest assured that before any new feature is released, these are thoroughly tested by the team. However, there always is the chance that things might not work for everyone and we appreciate the efforts of members of the community such as you to report these issues so they can be addressed. Should there be any other concerns that need to be brought up, please let me know. Thank you!

    #1947889

    rachelmcr
    Staff

    Hi dreadedsoftware,

    Our team fixed up the issue with the code shortcode. Sorry for your trouble with that earlier! Can you give it another try and let us know how it goes?

    #1947898

    This is closer. No longer are the br tags showing but the other special characters are being swapped out for their ampersand code including the ampersand so this effect now compounds. So, a less than symbol becomes ampersand lt semicolon, which becomes ampersand amp semicolon lt semicolon, which becomes ampersand amp semicolon amp semicolon lt semicolon, ad infinitum.

    @1tess: We are all in this together. Whether you are a user of WordPress or a developer for WordPress, this issue would be frustrating. Please be mindful of this when posting comments. Although you bring up a few good points, you do so with an accusatory (quite frankly rude and unhelpful) tone.
    The developers cannot be expected to be perfect; all we can expect is that they react quickly when issues do come up. To this end I believe they have exceeded expectations. Although the product is not yet production ready, I believe with some constructive feedback they will be able to resolve this issue in short order.
    Don’t let a small inconvenience pollute your perception of an otherwise solid product. After all, they have offered a workaround using the wp-admin facilities.

    #1947899

    Thanks for checking that out! I was able to replicate that issue and I’ve reported it back to the dev who was working on this.

    And thanks so much for your response here. We really do take all user input to heart and we love getting feedback from you so we can make WordPress.com better. While the home page editor is a work in progress, so is all of WordPress.com. It doesn’t mean we haven’t done extensive testing. However, we’re a pretty small team, there’s always going to be some bug that our millions of users find that we would have never found on our own.

    User reports are what make WordPress.com what it is. :)

    #1947900

    Is there a status update here?

    #1947901

    raincoaster
    Member

    Seriously, the New Post button is the biggest single source of problems in WordPress.com. It needs fixing, and it needs taking offline until it is fixed.

    #1947902

    Hi there!

    I’ve just pinged the developer for an update. I’ll let you know when I hear back, and I’ve put a reminder on my calendar to check in again if I don’t hear back from them tomorrow.

    @raincoaster – I’m not sure I know exactly what you mean. As far as I’m aware the New Post button works as expected. Are your referring to issues with the editors? or are you seeing issues with the button itself?

The topic ‘How do I disable automatic post changes?’ is closed to new replies.