Need help? Check out our Support site, then

How do I enable comments>

  1. thebestoftheinternets

    When I look at my blog I don't see a place to comment.

    I thought comments were enabled by default.
    The Help says to go to Settings>Discussions to manage comments.

    When I go to settings, I don't see Discussions listed.

    The blog I need help with is

  2. thebestoftheinternets

    I changed the theme and now comments are enabled.

  3. I can verify that comments are open on your blog. The way the comments function is coded into the core of WordPress and we cannot change this. Unless you use P2, a twitter-like theme, comments are collapsed on the front page of your blog where our posts are "showcased". By clicking the post title or the comments link the posts on the front page open on their own page where all comments display.

    The reason for this structure is that in a new blog one does not have many posts or comments. In an established blog if the comments did not collapse on the front page it would become a mile long in no time flat and page loading time is a page ranking factor. We have only seconds before visitors refuse to wait and click out.

  4. P.S. The theme change to Able made no difference. They were already open when I checked the blog before that.

  5. This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.

    We can also override the default settings and enable or disable future comments on any individual post or page.

    Note: By default, new blogs on will have the Discussion hidden. You can reveal it by clicking on Screen Options on the top right corner of your Admin page, and checking the box that says Discussion so the module is included.

  6. thebestoftheinternets

    A little confusing, but thanks.

  7. Yes it is but rest assured that comments are open on your blog. :)

Topic Closed

This topic has been closed to new replies.

About this Topic