Need help? Check out our Support site, then

How do I enable the visual editor by default?

  1. For some reason, the primitive editor comes up by default each time I save a post. It's quite maddening and only started happening. Is there a way to make it behave? I want the visual editor to be the default. If I want to go to primitive, I will use the tab.

    I have tried all the following:

    Switch to a different theme and it didn't help
    Looking through my profile for a setting to enable (or disable) and I can't find anything.

    Ideas? I'm using a hosted blog.

    The blog I need help with is

  2. Hmm, well I know that for me, if I click on the Text tab editor, and then go to a different post, it opens automatically in the Text editor. I don't know if that will help, but if you go to a post and make sure it's now in the Visual Editor, then go back to the Posts page, and open a different post, hopefully it will still be in the Visual Editor. If it's still happening, we'll let staff know, and see if they have any suggestions (or if anyone else does for that matter).

  3. Thanks so much for the reply. After a little investigating tonight, it appears that it's only happening in Internet Explorer 10. :(

    I mostly use IE. I tried Chrome tonight and it worked just as it has in the past, just as you describe in your reply. With IE 10, the editor keeps switching to the Text editor anytime I save or choose a new post. If there's a fix to tame IE10, I'd love to know about it. Meanwhile, looks like I'll have to A) get used to text editor (or constantly switching back) or B) use Chrome. :(

    Anyhow, thanks for the attention. I wrote it all up in case someone else is having a similar problem. I couldn't find anything about this using Google.

  4. I am having the same problem with not getting the visual editor as the default. Also the displayed font on the editor is smaller than it was when I last posted on July 4. I've spent most of the day googling and trying to figure out the source of my problem since I haven't changed my browser (still IE10 which it has been since it was released months ago). My last post was on July 4 and everything was ok then: visual editor as default and font size same as published size. HOWEVER, before I looked at my list of posts today, I clicked on "Have you tried our new quick post form yet?" I should never respond to come-ons of any variety since that is the only thing I did differently than usual. Would that have changed both the font size and default editor? How do I undo it?

  5. btw, I've just tried using Chrome with the same undesired results: text editor is the default and the font is smaller than it used to be.

  6. This morning, half of my problem has been resolved. The text editor is still the default so I have to switch to visual editor, but the latter is now displaying the same type font and spacing as the published post. Keeping my fingers crossed that the default editor will right itself before long. Oh, I just realized that I had to click the kitchen sink icon each time to get two bars of icons, not sure where that stands but will check it.

  7. I'll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  8. Thank you for responding so quickly. Now that the right font size and spacing are displaying, I can be patient while waiting. Two issues outstanding: 1) text editor is still displaying as default, and 2) only one bar of the toolbar displays when I switch to visual editor so I have to click kitchen sink each time to get full display.

  9. Hi frederickmb,

    I tested this out on IE10 and wasn't able to reproduce the problems you are describing. Can you please try a few troubleshooting steps for me and see if they resolve the issue?

    Please let me know if you continue to have trouble with this, and I'll keep looking into it!

  10. This is happening for me, too, once again. In IE, I cleared my cache, made sure all my browser extensions were turned off, as well as compat view. If I click a post, it appears in the text editor instead of the visual editor. I can click the visual editor to use it, but if I save or preview my post, it goes back to text editor mode. Very frustrating.

    This is happening in Chrome, too.

  11. I will run through rachelmcr's recommendations when I get back to my computer and post the results here.

  12. Followed rachelmcr instructions:

    1) Could not see that Compatibility View was on so didn't change anything.
    2) Disabled Shockwave Flash Object, Spybot -- Search & Destroy Config, and Spybot SD IE Protection.
    3) Cleared cache and cookies.

    This seemed to clear up my problems but only after I changed to visual editor and clicked kitchen sink on the first post displayed. After that, it worked ok on all posts. Since I have only a vague idea of what they do, I re-enabled the three add-ons above. The posts still display correctly and with the full tool bar. So I'm assuming that clearing the cache and cookies did the trick.

    Thank you for your help. If the problem doesn't recur, you won't hear from me again because I'll be busy writing posts!

  13. @frederickmb, I'm so glad it's fixed for you now! Please let me know if the problem returns.

    @ huckpilgrim, can you check to make sure you have cookies enabled in your browser? You can check here if you aren't sure:

  14. It says cookies enabled.

    It says Chrome 28.0.1500.71 (in Chrome) and IE 10 (In IE).


    I am still broken.

  15. Okay, wait. I am fixed today. I had to switch it back to visual and it does seem to stick this morning. Thanks for the effort. Not sure how that worked, but I won't complain.

    Well, not much at least. :)

  16. I'm glad it's fixed! It should stick with the editor you last used, so I'll cross my fingers for you. :) If the problem pops up again, please let me know!

Topic Closed

This topic has been closed to new replies.

About this Topic