How do I get rid of unwanted image borders when border=”0″??

  • Author
    Posts
  • #192784

    ruthomp
    Member

    Hey. When I upload an image – a clip-art.gif file, what I’ve noticed is that if I place the image in a text widget, I don’t have a border; if I try placing it in a post or page, I DO get a border even though the original code is set to border=”0″. I’ve tried uploading the image (via upload at the bottom of a post/page), I’ve tried inserting an image using the image icon in the body of the post/page, I’ve tried linking an image to it’s original source – all with the same result of an unwanted border when in a page or post only. Is there a reason for this difference?

    IF you’re looking for an example, please go to knitgirl63.wordpress.com and click on About MKG – the little graphic in there is exactly what I’m talking about.

    I tried to include as much detail here as I could; hope it wasn’t too much.

    #192989

    ellaella
    Member

    Have you tried linking to “none” ?

    (And please post only once. Most of us are volunteers.)

    #192998

    ruthomp
    Member

    Oh – sorry; I thought maybe I posted it in the wrong venue and needed to get it in the right one. I’ll remember that going forward.

    Yes – I tried linking to “none” and to “page;” didn’t try linking to file.

    #193004

    ellaella
    Member

    Linking to file will make it clickable and might produce a border; some themes I’ve used handle it that way. It’s worth a try.

    I know there’s at least one sort-of-recent thread about this but I did a quick search and it didn’t turn up. Maybe someone else remembers. Sorry. :(

    #193005

    ellaella
    Member

    Or it might be the fact that it’s a gif. If you can convert it to a jpeg with a transparent background, that might be the ticket.

    #193032

    ruthomp
    Member

    Thanks, ellaella. This certainly isn’t something that’s preventing me from having a functional blog; it’s more of an annoyance. So please feel free to go ahead and close this one out. Thanks again.

    #193035

    tisme
    Member

    ruthomp, that must be because of the theme style in use.

    in this situation you’ve got the following options (in no particular order):
    * switch to another theme;
    * buy a premium “Custom CSS” feature ($15/yr);
    * manually fix an image style whenever it needs to be borderless using an inline CSS style.

    for an infrequent usage of the latter method you might like to entertain switching to the code pane of the editor and changing your image markup by adding an inline style so that it looks something like that:
    <img STYLE="border:none" ... />

    so, in your particular example it should be exactly:
    <img style="border:none" src="http://knitgirl63.files.wordpress.com/2008/02/computer.gif" alt="computer.gif" />

    PS
    note so the someone else than original poster:
    currently google returns about 134 results from en.forums.wordpress.com for image border. most of the results start with or contain the verb ‘remove’.

    (of course, that’s just 0.007% of .com populace…)

The topic ‘How do I get rid of unwanted image borders when border=”0″??’ is closed to new replies.