How do I have only one post per page?

  • Author
    Posts
  • #716673

    hugsunny
    Member

    Whenever anyone goes to my blog it shows up as one long stream of posts…you scroll down endlessly. I want it to be so that a person can click to another post and only see one at a time. Also, when it shows up like this..they don’t see the individualized header picture I made for each post, and wouldn’t need to click to the page because they can read the whole thing right there. I tried to use the ‘more’ tags, but they aren’t showing up?

    The blog I need help with is endlessdiscoveries.wordpress.com.

    #716774

    Dashboard>Settings>Reading

    On that page there should be a ‘Blog pages show at most…’ option, and then you can just type one in there. For instance, I’ve typed ‘3’ for my blog, and if you have a look, only three show up.

    I don’t know what to say about the headers, but I’m sure someone else will be along to help soon :)

    #716775

    hugsunny
    Member

    Thank you. I changed that in there to one, but when I go to my page from the outside..it always has the ‘mountain’ header that is my ‘homepage’ one. For each of my postings I have made an individual themed heading, but unless you click on the heading of my post it doesn’t take you to the individualized theme page…and no one is going to do that if they can read the whole thing right there on that page. I tried inserting the ‘more’ tag, but I don’t see it working or showing up at all?

    #716776

    hugsunny
    Member

    Thank you. I changed that in there to one, but when I go to my page from the outside..it always has the ‘mountain’ header that is my ‘homepage’ one. For each of my postings I have made an individual themed heading, but unless you click on the heading of my post it doesn’t take you to the individualized theme page…and no one is going to do that if they can read the whole thing right there on that page. I tried inserting the ‘more’ tag, but I don’t see it working or showing up at all?

    #716777

    timethief
    Member

    @hugsunny
    I’m not sure if you have worked this out or not. When you click through to a specific post away from the home page, the header changes to whatever the featured image is on the post. If you remove a featured image, your custom header image will be displayed.
    http://theme.wordpress.com/themes/twentyten/

    #716785

    hugsunny
    Member

    Whenever I put my address into the url to see how it looks to an outsider “www.endlessdiscoveries.wordpress.com” it automatically shows my last post and the header picture is my homepage picture (mountains) it’s supposed to be a couch. If you click on the header and go to the post page it shows up correctly..but no one would click on it, because the entire post shows up on the page. I tried to make it so the public see’s only part of it and has to click through with the ‘more’ but it’s not showing up.

    #716830

    timethief
    Member

    That’s the way featured images function. Have you read this support entry on featured images?

    #716845

    hugsunny
    Member

    Yes, sorry I had read that before. I have never removed any of my featured images. I basically was wondering why the page automatically shows my ‘custom header’ for the homepage…and not the specific header for the page as I want it to. The only way that people could see that header would be if they click on the blog post, and they won’t do that because they can read the whole thing on that page. I have tried inserting the more tag into every single one of my posts and it’s not working. I wanted it to be so that they could see 3 posts, and click on the one they want, and not just see my last post in full view.

    #716891

    Featured images replace the regular header image when you view a single complete post. The homepage displays the regular header image. So I don’t see what else there is to understand. Your readers will view a single complete post if they land on it via a link, or if they click on its title, or if you use the more tag, as you said. But you haven’t inserted the more tag in any of your latest posts. What do you mean by “it’s not working”? If you tried to check it by previewing the post, then of course you won’t see it working: the more tag works on the main page, not when you view a single post.

    #716895

    hugsunny
    Member

    Sorry, but I did insert the ‘more tag’ in all of my posts. It’s written as “Keep Reading”…. but if I go to the site as an outsider and just enter my blog address.. it takes me to my last post. If I click on ‘Home” it automatically goes to the last post, and I never get to a spot where I can see the ‘more’ tag. I’m sorry if I’m misunderstanding something easy… I am just trying to make it work the way I want it. Thanks for all your help.

    #716897

    timethief
    Member

    Panos probably clicked your username and went to that blog. The URL for the blog in question is this one http://endlessdiscoveries.wordpress.com (www) is it not? If so, then there are no “read more” tags inserted into the posts on the front page of that blog.

    #716900

    hugsunny
    Member

    I didn’t put any on the “Who am I page” but on every other post I put a <!–Keep Reading–>
    I even just the page source and it’s there in a faded green. (I clicked on the link in your forum post and it went directly to the couchsurfing post..and then I right clicked and checked page source)

    I’m not sure why it’s not working.

    #716911

    @TT: That’s the blog I checked too.

    @hugsunny: I see now. You tried to create a customized version of the read-more tag, but you didn’t do it correctly. If you want it to say “Keep Reading”, this is what you should paste:
    <!--more Keep Reading-->

    #716913

    (In the HTML editor, of course.)

    Or place the cursor at the right point, click the more button then modify it (by adding a space and your text after the word “more”, not by replacing it with your text).

    #716932

    hugsunny
    Member

    Thank you Thank you Thank you!

    #716934

    You’re welcome!

    #716936

    By the way, the drawback with the more tag is that it will link to the rest of the post, so a visitor won’t see the featured header image at once. There’s another trick you can use to make the homepage excerpt link to the top of the post, but it’s more complicated (especially if the post includes images), and you won’t be able to customize the more link. Anyway here it is, in case you’re interested:
    http://wpbtips.wordpress.com/2011/08/18/gallery-format-as-custom-excerpt/

    On a different issue: the images you’ve been uploading and inserting are unnecessarily large. For future posts you’d better make copies of your imagess, downsize them in an image editing application to a resolution of 72 (which is what all browsers display) and to a width no larger than the maximum for the theme you’re using. This way your posts will load faster, you save storage space, and you getter better quality too. See here:
    http://wpbtips.wordpress.com/2010/01/16/image-quality/
    http://wpbtips.wordpress.com/2009/07/23/maximum-image-width/

    Except if you do want the images in the posts to link to the real-size originals when clicked. But if that’s not intentional, see here:
    http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/

    #716940

    hugsunny
    Member

    Thank you very much I will check those suggestions out. I appreciate the time you have taken to help me.

The topic ‘How do I have only one post per page?’ is closed to new replies.