How do I import attachments?

  • Author
    Posts
  • #926235

    I am trying to move the contents of one of my self-hosted blogs to a WordPress.com blog, but when I import, the attachments are not included. I do not see an option to select “Upload attachments.” They show up in the WordPress.com blog, but are hosted on my old host server, not WordPress.
    Blog url: http://giantmuh.wordpress.com/

    The blog I need help with is giantmuh.wordpress.com.

    #926369

    timethief
    Member

    That’s strange as what I recall when importing an XML file was is a prompt appearing asking me if I wanted to include the attachments. I flagged this thread for Staff attention.

    #926373

    Thanks. In this test entry…

    http://giantmuh.wordpress.com/2012/05/09/abby-cakes/

    …there should be a photo. The image was hosted on iPower.com, but when I deleted it from iPower, it is gone from the WordPress entry, so WordPress did not import it.

    #926607

    Is there any word on this? I have tried several more times, yet the images are not importing, but remain hosted at richardbarron.net.

    #926608

    timethief
    Member

    Hi there,
    I have flagged this thread for Staff help.

    #926609

    auxclass
    Member

    The image was hosted on iPower.com, but when I deleted it from iPower, it is gone from the WordPress entry,

    I think WordPress would have imported the LINK to the picture but not the picture. When the picture was deleted the link would not point to anything. You hot linked to the picture on another web site.

    #926610

    >>You hot linked to the picture on another web site.<<

    When I originally posted it to my web site, richardbarron.net, a WordPress-based site, I uploaded the photos to each entry. I am now trying to migrate to WordPress.com, but it does not import the photos, only links to richardbarron.net. I am trying to find a way to import the entire entry, including attachments, to my WordPress.com blog from richardbarron.net.

    #926611

    auxclass
    Member

    If your WordPress.ORG blog was on richardbarron.net and the pictures in your media library then the setting @TT referenced above should have brought the pictures with the import.

    #926612

    “Should have,” but did not. There was never an option in either export from richardbarron.net nor import to WordPress.com to include attachments. I tried it using both Safari and Firefox.

    #926613

    macmanx
    Staff

    I see that you have 3,391 items in the media library now. Perhaps it just took a few minutes to complete.

    #926614

    I saw the items in my media library. However, they were not attached to any posts. They’ve been there since I first tried to import, several weeks ago. I’m going to try deleting them all, and attempt a clean import.

    #926615

    macmanx
    Staff

    Ok, please let us know how it goes!

The topic ‘How do I import attachments?’ is closed to new replies.