How do I make a line break (i.e. “hard return” or “new paragraph”)?

  • Author
    Posts
  • #177165

    essemelle
    Member

    From a complete beginner…. please, please can you help? I have searched all of the forum pages and FAQs and can’t find an answer…maybe because it’s too basic for anyone to bother with. But after a week of trying to find an answer I’m going crazy with frustration:

    I CANNOT figure out how to make LINE BREAKS.
    In normal word processing (or even plain, old-fashioned typing!) it’s what happens when you press “Return”.
    And I also can’t make a “double line space” or “new paragraph”….. i.e. what happens in word processing when you hit “Return” twice.

    When I write the content it looks fine (with spaces between the lines) but when I save and publish it, the entire page shows up as one huge block. It’s horrible.

    Somebody suggested that I do “Shift + Return” but that doesn’t make any difference.

    I am working on Mac + Safari.

    Please can you help to make this new year happy.

    Thanks!

    #177532

    mark
    Staff

    This is Safari.
    Currently the latest Safari and our editor do not play nice. Tinymce who make our editor say it should work, Apple say it should work. It doesn’t and unfortunately we do not have the cure right now. I can only suggest using Firefox or Camino for the time being.

    #177533

    essemelle
    Member

    Thanks, Mark. I will try Firefox now and let you know what happens there.

    BTW My Safari is Version 3.0.4 (523.12)

    #177535

    essemelle
    Member

    Mark…. thanks a million. It all seems to be working in Firefox. Oh, the relief!

    Happy new year.

    #177690

    jikoryu
    Member

    Thank you. I had the same question and I wasted an hour trying to figure it out…

    #177693

    katymunger
    Member

    Has anyone made any progress on this — I have this problem even when I use the latest version of FireFox — if I use the built-in editor to insert a line break, it does not show up. If I add in the code manually, it will show up the first time I check it (sometimes) but then disappear thereafter. Much of the time, it doesn’t even show up on first viewing.

    It’s driving me nuts. Anyone found any tricks? I thought hand-coding in a blank space and then hand-coding in

    might do it for awhile, but that disappeared form the coding as well.

    Thanks if anyone has found a solution. I am also on a Mac. (I do have access to a PC. If I do it on the PC, will it stick?)

    #177694

    handpicked
    Member

    I ‘ve been having the same problem except I don’t know the code for a line break…even though using the built in editor I shouldn’t have to ??

    #177695

    In the code editor, put this on the line between the paragraphs<p>&nbsp;</p>

    #177696

    @mark

    One thing to note is that all you have to do is tell TinyMCE that you are not Safari (debug menu > user agent > choose Firefox) and the editor works fine. Something in the Safari specific hacks in TinyMCE is causing the issue. When Safari is set so that it tells TinyMCE that it is Firefox, everything is fine with the editor and linebreaks.

    #177697

    raincoaster
    Member

    There was also an error, which I’ve seen before, last night which turned all P tags into Div tags on posts you were working on for a certain time period. If you do in and change them back, you get your spacing back. It’s weird.

    #177698

    tophocles
    Member

    I hope this gets fixed soon… Safari is by far my preferred choice of browser on Mac OS X, and WordPress is by far my preferred blogging solution.

    #177699

    heres a random question i just figured id ask anywhere im having an issue with the dates posted on my blog they are completely wrong when someone leaves a comment the date and time given is off by a day or at least several hours can anyone help?

    #177700

    isadora
    Member

    encounteryouths, please open a new thread for a new question. You’ll have to insert the time difference (UTC + or – n hrs) in the field “Times in the blog should differ by:” under “Options” > “General” in the “Date and Time” section.

    #177701

    fifthdecade
    Member

    I am using Firefox on Mac and have the same problem as the OP. Spaces between paragraphs exist until I publish, and then I get a mass of text. This is NOT just a Safari thing. This is a WordPress thing as it does not happen anywhere else. The only way I can fix it is to add the < br > tag while in the Code view and then publish. As soon as I edit the post eg when I click on Save and Continue Editing, or when I Publish and then Edit the big block of text returns.

    What can be done? This is seriously frustrating. It stops me adding links, images and other writing aids.

    #177702

    raincoaster
    Member

    If you’ve looked at the code, please let us know whether you’ve got Div tags or P tags as the default when you hit Return. Div tags have been causing all kinds of issues for the past few weeks.

    #177703

    The posts on his site have p tags (and line breaks). I expect when they go through the editor they get converted to div’s. Nothing out of the ordinary in his published posts.

    #177704

    There is another thread going on about this, which I cannot find. I am having the same problem. Furthermore, I am having it on both Mac and PC, with both Firefox and Safari.

    One thing I wish … when I click on Code, I want to enter my own line breaks and return characters. A visual editor can strip things out, but not a Code editor. I recognize that some HTML tags have to be stripped out, because they would be to difficult to support, but other than that, I would at least like to see the Code editor run on the principle, “what you type is what you get.”

    Howard

    #177705

    You can turn off the visual editor. Go to users > my profile and uncheck “use visual rich text editor” and click “update profile.” That will take care of the paragraph spacing issues.

    #177706

    lazyaussie
    Member

    Sacred P. I used <p> </p> to try and make a line break in a text widget, but it makes a huge space. I just want to make sure the text starts on the next line. (I want to make a list of the best posts but I can’t stop them merging into each other or having a huge space).

    #177707

    Use the linebreak tag<br /> at the end of the line and all text will start on the next line after it.

The topic ‘How do I make a line break (i.e. “hard return” or “new paragraph”)?’ is closed to new replies.