Need help? Check out our Support site, then

How do I make a private blog public?

  1. I first had the blog private while I was experimenting and getting feedback from a few friends. I now want to make the site public. I have checked the box in reader settings to "allow search engines to access this site". It still is giving people the message that my blog is private and they need to log in.

    The blog I need help with is

  2. Your site is correctly set to be public.

    Would it be possible to upload a screenshot of where you see the message that the blog is private, to help in troubleshooting?

    Here's a guide on how to make a screenshot, if you're not sure:

    Just upload the screenshot in your Media Library and then post a link so I can see it. Thanks!

  3. I am having the same problem. If I post my URL on someone's Facebook page, it asks them to login. Http://

  4. This is what appears when I post the link.

    Protected Blog › Login is marked private by its owner. If you were invited to view this site, please log in below. Read more about privacy settings.

  5. Your blog isn't protected, but it looks like you need to flush the Facebook Cache.

  6. bbyrdgiles - as raincoaster suggested, it sounds like you just need to refresh Facebook's stored (cached) version of your site. You can do that very simply by pasting into the text field on the page below and then clicking "Debug":

    Let us know if this works.

  7. THANKS!!!

  8. My pleasure!

  9. ninasbreakfast

    My original question was corrected when I went and deleted all the people who I had invited when it was a private blog. After I did this, the blog became public.

  10. That's great news. Thanks so much for posting and sharing it here. Happy blogging.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.