How do I make comments reappear after I disabled them?

  • Author
  • #1140032


    I was getting a lot of spam on a post titled “Are some people better than others.” I had two legitimate comments on it already. I notice spammers always target the previous week’s posts. So I decided to disable the comments, thinking that in another week I would enable it again. After doing so it still shows comments as off and the two legitimate comments do not appear. I can see them on my preview but not on the live page. Can this be fixed?

    The blog I need help with is



    Yes. This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.

    Take note of this: Other comments settings

    3. Automatically close comments on articles older than __ days – This setting can be used to have comments closed on articles that are X days old. As an example, if you only want articles to accept comments for 30 days you would check the box and type 30 into the text field.

    We can also override the default settings and enable or disable future comments on any individual post or page.

    Note 1: By default, new blogs on will have the Discussion hidden. You can reveal it by clicking on Screen Options on the top right corner of your Admin page, and checking the box that says Discussion so the module is included.



    Thanks for the info. Ideally I would like for old comments to remain on the blog but I would like to close comments after one week. It seems once the comment is closed, all comments are invisible on the screen. Any suggestions?



    “It seems once the comment is closed, all comments are invisible on the screen.”
    That’s not correct: it happens in very few themes, and yours isn’t one of them. The post you referred to displays the existing comments (although commenting is closed):

The topic ‘How do I make comments reappear after I disabled them?’ is closed to new replies.