How do I make the full post display — not just an excerpt?

  • Author
    Posts
  • #997783

    I’m trying to get full posts — not excerpts — to display on the front page. I’ve made sure that I’ve marked “show full post” under “Reading,” and none of the posts are employing the <more> function. I’ve tried changing the template, and that doesn’t work either.

    Help would be much appreciated!
    Blog url: http://whitmantv.wordpress.com/

    The blog I need help with is whitmantv.wordpress.com.

    #997928

    timethief
    Member

    There are several ways of splitting content. http://en.support.wordpress.com/splitting-content/ The most commonly used one is inserting “the more tag” http://support.wordpress.com/splitting-content/more-tag/ into posts so only excerpts appear on the front page.

    #997929

    No, I *don’t* want the content to be split — it’s doing it automatically. I want the full post to appear, not an excerpt.

    #997930

    timethief
    Member

    Changing your RSS Feed for posts to “summary” here . Settings > Reading changes that only in the RSS Feed and not on the front page of the blog.

    #997931

    timethief
    Member

    oops! sorry.

    re: Grisaille and any theme with an active excerpt box you can use this workaround
    You compose your whole post first and before you publish it you switch to the HTML (Text) editor, copy the code, paste it into the Excerpt box, and publish the post. http://en.support.wordpress.com/splitting-content/excerpts/#creating-excerpts

    If you do not see an excerpt box then go to screen options on the top right hand corner of your Admin page and include:
    Post – Likes and Shares, Format*, Categories, Tags, Excerpt, Send Trackbacks, Discussion, Comments**, Slug, Author, Revisions, Writing Helper

    P.S. On themes that do have an active excerpt function, the workaround works very well but you have to do it on every post you create.

    #997933

    Okay — so what do I do to make it so the whole post appears on the homepage?

    #997937

    So it’s a problem with the theme — it automatically uses excerpts? That’s super annoying! Thank you, though, for all your help —

    #997938

    timethief
    Member

    The theme is designed to provide only excerpts but you can override that. We were typing at the same time. Please see what I posted above.

    #997940

    timethief
    Member

    I don’t know why you consider the theme to be super annoying. I think what’s causing your issue with it is assuming that all themes are designed to display whole posts when they are not. That was the past. This is the present. The present demand is for themes that display excerpts in magazine style formats. The future demand will be for themes that have post formats. Fortunately our Theme Team has provided a wide selection of 200 themes which is growing to meet all needs. http://theme.wordpress.com/

The topic ‘How do I make the full post display — not just an excerpt?’ is closed to new replies.