How do I remove the header text in Twenty Eleven and not mess up the menu bar?

  • Author
    Posts
  • #1039491

    msmidt
    Member

    When using my own header (or even one of the built in header pictures) in the Twenty Eleven theme and with the Header text active, the menus for my blog go all the way across the page in one line.

    However, when you remove the header text, the menus get thrown into two lines.

    How do I remove the header text but still have the menus in just one row all the way across the page?

    Thanks.
    Blog url: http://eaglesonblondeau.wordpress.com/

    The blog I need help with is eaglesonblondeau.com.

    #1039588

    macmanx
    Staff

    Ok, that is very odd. Do you see any differences if you build and set your own primary menu? http://en.support.wordpress.com/menus/

    You have built one already, but it has not been set as the primary menu yet.

    Also, I apologize if you have the wrong header image now. I hit the wrong button when testing, but I think I put the right one back up.

    #1039591

    msmidt
    Member

    Actually, I was using the new menu that I built, but it was messing up the “Home” setting on the menu, so I just went back to the default menu. It had been working fine.

    The header image you have in there now is the one I was trying to get to work. But to make it work, I need to uncheck the header text. (That way the header text doesn’t say “Eagles on Blondeau” and the new header also has the “Eagles on Blondeau” logo on it.) And when I uncheck the header text, that’s when the menus go to two lines deep.

    Appearance>Header>”Uncheck” Show Header Text with your Image

    Any new thoughts?

    #1039592

    macmanx
    Staff

    Try the Custom Menu again, but add Home as a Custom Link. That will solve your problem of Home displaying.

    I’m curious if the Custom Menu will resolve the problem. At the very least, it will give us more to work with.

    #1039594

    msmidt
    Member

    I tried to do this againm, but it creates other problems. I may be constructing it wrong but…

    The problem I have with creating a “Home” on the custom menu is when you do this, you then have the word “Home” as the top headline on that page. At least that’s what happens when I create a page and labeled it Home and put it in the custom menu.

    That’s why I went back to the default menu. The default menu puts a Home link in the menu bar, but also allows you to have the page “Available January 2013” as the home page or landing page or whatever you call it.

    #1039595

    msmidt
    Member

    I did have some CSS, but I stripped out all the CSS except for the part that removed the search bar from the top of the page.

    Also, I do have “order numbers” filled in for the Menus.

    #1039596

    macmanx
    Staff

    No, don’t create a page for Home. Use the Custom Menu and set a Custom Link.

    I’ve done that for you, but still see the problem. I’m trying a few more things.

    For working with the menu, please see this for a video tutorial: http://en.support.wordpress.com/menus/

    #1039597

    macmanx
    Staff

    Ok, I see the problem. When Header text is disabled, the Search bar is moved into the menu area.

    Unfortunately, the element is there and cannot be removed, only hidden, so its form will always break the menu into two lines.

    In this case, I’d recommend either using a shorter menu, or just don’t hide the search field.

    #1039604

    msmidt
    Member

    Thanks so much. Since the solution may be to not hide the search field, this leads to another question.

    I have two blogs: inthedeed.wordpress.com and eaglesonblondeau.com

    Is there a way to make the CSS only work on one of the blogs? I really only want to hide the search field on one of the blogs.

    #1039605

    macmanx
    Staff

    Unfortunately, not in this case. You’re getting the Custom Design upgrade as part of the bundle, which includes your domain registration, so I can’t move it away from eaglesonblondeau.com.

    #1039606

    msmidt
    Member

    Well, thanks for all the help. I guess I’ll create some submenus and make the menu bar shorter.

    Thanks!

    #1039607

    macmanx
    Staff

    You’re welcome!

The topic ‘How do I remove the header text in Twenty Eleven and not mess up the menu bar?’ is closed to new replies.