How do I solve a XMLRPC 32700 connection error?

  • Author
    Posts
  • #1057017

    Hi there

    I’m really struggling to connect JetPack to my WordPress blog. My suspicion is that it has something to do with my new hosting configuration on EC2 (just moved it there over the weekend).

    My URL is http://www.streamfoundations.com and I’ve passed the xmlrpc.php test

    The current environment is:
    Jet Pack 1.9.1
    Wordpress 3.4.2
    Micro Ubuntu 10.11 EC2 Install / nginx / mysql
    Amazon Security allowing HTTP/S
    Ubuntu Firewall allowing HTTP/S
    Theme is custom built

    Additional Plugins are:
    – Akismet
    – Amazon SES DKIM Mailer
    – Contact Form 7
    – Flamingo
    – W3 Total Cache (Minify & Object Cache disabled)

    Troubleshooting steps to date and have failed
    – turned off all plugins and reverted to default Twenty12 theme
    – turned off Ubuntu firewall
    – cleared old blogs on wordpress.com
    – allowed all TCP traffic on Amazon instance

    I’m pretty much out of ideas and there isn’t much on the web about this!

    Please help!

    Cameron Church
    Blog url: http://www.streamfoundations.com/

    The blog I need help with is www.streamfoundations.com.

    #1057169

    Hi Cameron,

    Using the Jetpack debug page, it looks like XML-RPC isn’t responding correctly on your blog. In Settings -> Writing, can you check that XML-RPC is enabled?

    If it is, can you see if your host blocks XMLRPC?

    #1057218

    Hi Bryan

    Thank you for your quick response – much appreciated! So here is the problem I’m having.

    In the WordPress Admin after Jetpack fails to connect it says when I browse to http://www.streamfoundations.com/xmlrpc.php ” It should show ‘XML‑RPC server accepts POST requests only.’ on a line by itself when viewed in a browser and should not have any blank links or extra output anywhere.” which is does both via the URL and via the curl instruction via the Debugger Page.

    So the net is the Debugger Page is saying it’s not working and tells me to run a curl script. The output of is is:
    curl -X POST -H ‘Content-Type: text/xml’ ‘http://www.streamfoundations.com/xmlrpc.php’
    XML-RPC server accepts POST requests only.root@ip-xx-xx-xx-xx:~#

    which is what I’m supposed to be seeing according to the Plugin’s error!

    So the debugger is saying it’s not working and the plugin is saying the response is as expected!

    Any further thoughts would be greatly appreciated!

    CC

    #1057220

    OK I got it now – much thanks to you Bryan and to this thread https://en.forums.wordpress.com/topic/jetpack-instl-issue-with-ssl-and-lighttpd?replies=18

    Basically my problem wasn’t with lighttpd but with varnish (same sh*t different smell) – I was routing my nginx traffic through varnish and that was causing a cache issue that Jetpack didn’t like

    For those of you who are following this thread http://www.ewanleith.com/blog/900/10-million-hits-a-day-with-wordpress-using-a-15-server then know that the varnish implement (at the time of writing this) doesn’t work with JetPack.

    Now for my next trick in tracking down a fix to the varnish config ala lighttpd (or just using lighttpd!)

    Thanks again

    #1057228

    Excellent work! You found the related forum thread in such a short amount of time after your last reply, too. I love it. :-)

The topic ‘How do I solve a XMLRPC 32700 connection error?’ is closed to new replies.